summaryrefslogtreecommitdiff
path: root/dev-python/fritzconnection
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-20 09:41:00 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-20 09:41:00 +0100
commit1def2e3dbbf3c86abad238d1118502cfe7f61f08 (patch)
treef68c70d85f32fd90003e7af6f1aab202b0868e9e /dev-python/fritzconnection
parenta40d7aa891556e7984504838ea13099a5ca12802 (diff)
gentoo auto-resync : 20:08:2023 - 09:41:00
Diffstat (limited to 'dev-python/fritzconnection')
-rw-r--r--dev-python/fritzconnection/Manifest2
-rw-r--r--dev-python/fritzconnection/fritzconnection-1.13.0.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/fritzconnection/Manifest b/dev-python/fritzconnection/Manifest
index 1463fb55b490..2d0673748837 100644
--- a/dev-python/fritzconnection/Manifest
+++ b/dev-python/fritzconnection/Manifest
@@ -1,3 +1,5 @@
DIST fritzconnection-1.12.2.gh.tar.gz 157170 BLAKE2B 9d924ad3146361d9301f10154152cdf98987572880b79052bf9f2fa427fc8410bacae92e49219dd11372c2cce2d03fb0ffd4c732a45e210a05a0a561ba5fc155 SHA512 a9c62fdaa59f20e7661836888f49cadfc99d192c393f34d4cce59aa9b9a9eda162e25029933854e84de44e08190190f312bb3862d708e79d7cf1ee8496726eab
+DIST fritzconnection-1.13.0.gh.tar.gz 160654 BLAKE2B e3ed78640a015d2dc785b2e04f32f6d4e81ba88bf4d823cd643e0f4ebc2ec8396c79c8e368012944f5809512a05d6d4715cdf7d0d76e518479a0a77e20350fae SHA512 6776ba37b52a80eee57a77a75f7815491a575ab8a1c36d20633b39d61e8f0fc295c1ec1d20bb6620e43854b954d9fd044e88d0344a10c0b3707fffb3edc733a4
EBUILD fritzconnection-1.12.2.ebuild 987 BLAKE2B d5c072aff514a0289c58409de6d07f463ed45770313a973f8d7bcbf9ed20ede39065014275412d7866b4fb505fa967221a866ebd8116053aea3801c0444fbec7 SHA512 c95c3d57494f42433d8d7ac3da6d7a8f56184161f0ba497857e157fdf15b5fd21793c18ceb4dcb1aed9bbdf0c3a1e53c4f0172eeb7aeecfa5bab09f68216ec9c
+EBUILD fritzconnection-1.13.0.ebuild 1095 BLAKE2B 07a013c6f0ee8cc0217b8e1431692d3722bd0c9671196a77ca398974f4144105ae4d67cb916fa162be7dcb16ab1484609b9df667c2ec7eee423cee83c3a80115 SHA512 dcadad7241b44b8fb0783676099aae7b5c24413b51fb0a218bbe1dd14be07ad21a70499166d4aaa4ad5834e3262e23e6781fab5cbab56eff27ef66dcb7d73ff8
MISC metadata.xml 469 BLAKE2B f180fca33d0ab2fc81dc87fd39db87cf8c8ff51777062968a3ace592c9ac63af311273fda2db88c6772204ae24c21b4f195d1b7bacbb3c23f677dc7e8e309f1d SHA512 9ab24725dc0bb5b0e40ce79520d19c0348b08c7d779b53064111aa53fefefadc164b6140310df0a367d460d2fbb46345bdb2b7b6a9cf1beba3bbab1f7d7e2697
diff --git a/dev-python/fritzconnection/fritzconnection-1.13.0.ebuild b/dev-python/fritzconnection/fritzconnection-1.13.0.ebuild
new file mode 100644
index 000000000000..b1bee82fa217
--- /dev/null
+++ b/dev-python/fritzconnection/fritzconnection-1.13.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Lib/tool to communicate with AVM FRITZ! devices using TR-064 protocol over UPnP"
+HOMEPAGE="
+ https://github.com/kbr/fritzconnection/
+ https://pypi.org/project/fritzconnection/
+"
+
+LICENSE="MIT"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/kbr/fritzconnection"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/kbr/fritzconnection/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~x86"
+fi
+
+RDEPEND="
+ >=dev-python/requests-2.22[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # flaky (relies on time.sleep(0.01) magically being sufficient)
+ fritzconnection/tests/test_fritzmonitor.py::test_terminate_thread_on_failed_reconnection
+ )
+
+ # "routertest" marks tests against live hardware
+ epytest -m "not routertest"
+}