summaryrefslogtreecommitdiff
path: root/dev-python/fritzconnection/fritzconnection-1.12.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-09 22:25:44 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-09 22:25:44 +0100
commit796e724b5ace96ff70d918765662edf62f1d8c85 (patch)
treeb09742996db0de2a2414587542b1b91d4ae5c522 /dev-python/fritzconnection/fritzconnection-1.12.2.ebuild
parentcd7ab3ad114e9777d85ced67abdd5b25d0bd4efe (diff)
gentoo auto-resync : 09:07:2023 - 22:25:43
Diffstat (limited to 'dev-python/fritzconnection/fritzconnection-1.12.2.ebuild')
-rw-r--r--dev-python/fritzconnection/fritzconnection-1.12.2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/fritzconnection/fritzconnection-1.12.2.ebuild b/dev-python/fritzconnection/fritzconnection-1.12.2.ebuild
new file mode 100644
index 000000000000..4f3353259b28
--- /dev/null
+++ b/dev-python/fritzconnection/fritzconnection-1.12.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Lib/tool to communicate with AVM FRITZ! devices using TR-064 protocol over UPnP"
+HOMEPAGE="
+ https://github.com/kbr/fritzconnection/
+ https://pypi.org/project/fritzconnection/
+"
+
+LICENSE="MIT"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/kbr/fritzconnection"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/kbr/fritzconnection/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~x86"
+fi
+
+RDEPEND="
+ >=dev-python/requests-2.22[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # flaky (relies on time.sleep(0.01) magically being sufficient)
+ fritzconnection/tests/test_fritzmonitor.py::test_terminate_thread_on_failed_reconnection
+)