summaryrefslogtreecommitdiff
path: root/dev-python/freezegun/freezegun-1.2.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-13 14:24:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-13 14:24:01 +0100
commitb392cbf078526e18db5d54ec37f9580be480fd48 (patch)
treef2f8f60717bb0fbe3df7452c2e0b1e0c192341d1 /dev-python/freezegun/freezegun-1.2.2.ebuild
parentcd40bc9ab405aca4e72f869db79d9d1ff77d8313 (diff)
gentoo auto-resync : 13:08:2022 - 14:24:01
Diffstat (limited to 'dev-python/freezegun/freezegun-1.2.2.ebuild')
-rw-r--r--dev-python/freezegun/freezegun-1.2.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/freezegun/freezegun-1.2.2.ebuild b/dev-python/freezegun/freezegun-1.2.2.ebuild
new file mode 100644
index 000000000000..553b4713ec6b
--- /dev/null
+++ b/dev-python/freezegun/freezegun-1.2.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Let your Python tests travel through time"
+HOMEPAGE="
+ https://github.com/spulec/freezegun/
+ https://pypi.org/project/freezegun/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+RDEPEND="
+ >dev-python/python-dateutil-2.7[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ )
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ # https://github.com/spulec/freezegun/issues/396
+ # https://github.com/spulec/freezegun/pull/397
+ "${FILESDIR}"/${PN}-1.1.0-py310.patch
+)