summaryrefslogtreecommitdiff
path: root/dev-python/freezegun/freezegun-0.3.12-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-python/freezegun/freezegun-0.3.12-r1.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-python/freezegun/freezegun-0.3.12-r1.ebuild')
-rw-r--r--dev-python/freezegun/freezegun-0.3.12-r1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/freezegun/freezegun-0.3.12-r1.ebuild b/dev-python/freezegun/freezegun-0.3.12-r1.ebuild
new file mode 100644
index 000000000000..bef9ce1ee62a
--- /dev/null
+++ b/dev-python/freezegun/freezegun-0.3.12-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_{5,6,7,8}} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Let your Python tests travel through time"
+HOMEPAGE="https://github.com/spulec/freezegun"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="test"
+
+RDEPEND="
+ >dev-python/python-dateutil-2.0[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ # pulled from upstream git, will be in next release
+ "${FILESDIR}/freezegun-0.3.12-py38.patch"
+
+ # test fixes
+ "${FILESDIR}/freezegun-0.3.12-tests.patch"
+)
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -r \
+ -e 's:(python-dateutil)>=2.0:\1:' \
+ -e "s:'(python-dateutil)>=[0-9.]+,.+':'\1':" \
+ -i setup.py
+
+ distutils-r1_python_prepare_all
+}
+
+python_prepare() {
+ # optional and only works with python3
+ if ! python_is_python3; then
+ rm ${PN}/_async.py || die
+ fi
+}