summaryrefslogtreecommitdiff
path: root/dev-python/formencode
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/formencode
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/formencode')
-rw-r--r--dev-python/formencode/Manifest3
-rw-r--r--dev-python/formencode/formencode-1.3.0-r2.ebuild45
-rw-r--r--dev-python/formencode/metadata.xml11
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/formencode/Manifest b/dev-python/formencode/Manifest
new file mode 100644
index 000000000000..02ab285cd3a5
--- /dev/null
+++ b/dev-python/formencode/Manifest
@@ -0,0 +1,3 @@
+DIST FormEncode-1.3.0.zip 347674 BLAKE2B 27cf411224338403036fc99eac5bbaf3d24d211afafae2689e638ea2d9c95f9475bf42246c9bbd50d748fa1d8aad14633da686f63cc409520455b593da0aed34 SHA512 12c7c9fa36173c209682a6e1d68a074c64c9a5bd30e4f6b6b851b55d43c350ce1f79f666a9176add65f6bde554bc5deeb82ac965005f9457c4c2b0447af0cea9
+EBUILD formencode-1.3.0-r2.ebuild 1295 BLAKE2B 829a7d52caf391236959921bc7a20347e2fce0a26734a22ce2962c7355489e9d16af64a7906010ee68097e9bfa25d72135b3d46f780461b9f38da8eaada396b3 SHA512 3cd0017e4b533756af55412477e9a85faaabfdc383704455f2a43208abe453a7ff4505a80037fe131d015086b50ebc28b281b0260dbc4a37bb8fd07a47516bcc
+MISC metadata.xml 313 BLAKE2B b2afc0db55b4200fc468745d4798933c54abac7014e1d3e87080d1601101cff2c6642b31a83b620e9b68b8181dfeeb0f6d8eedec6bedde9d3c5716ccaec7d229 SHA512 75c69f2f2ed7d4415bd057215675f4f4ed90b7c6ac1c402e61c6c2404600a5676298d3f0eeb58d287113ea34304e34ffe3731646d96264f776a37b0812d4db9b
diff --git a/dev-python/formencode/formencode-1.3.0-r2.ebuild b/dev-python/formencode/formencode-1.3.0-r2.ebuild
new file mode 100644
index 000000000000..bb0f9ccc442c
--- /dev/null
+++ b/dev-python/formencode/formencode-1.3.0-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+MY_PN="FormEncode"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="HTML form validation, generation, and conversion package"
+HOMEPAGE="http://formencode.org/ https://pypi.org/project/FormEncode/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="amd64 ~ia64 ppc ~sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="doc test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pycountry[${PYTHON_USEDEP}]
+ virtual/python-dnspython[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+RESTRICT="test"
+DOCS=( docs/. )
+
+S="${WORKDIR}/${MY_P}"
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
+ sed -e '/package_data.*..docs/d' -i setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # https://github.com/formencode/formencode/issues/78
+ # 5 failures under py2.7. Although the package claims to cater to py3, the suite fails horribly
+ # Main problem is that it is written requiring to be system installed, then run.
+ # Suite found to pass on extended testing using tox.
+ nosetests || die "tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/formencode/metadata.xml b/dev-python/formencode/metadata.xml
new file mode 100644
index 000000000000..3dc3b29a8a4f
--- /dev/null
+++ b/dev-python/formencode/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">FormEncode</remote-id>
+ </upstream>
+</pkgmetadata>