summaryrefslogtreecommitdiff
path: root/dev-python/formencode/formencode-1.3.0-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
commitb24bd25253fe093f722ab576d29fdc41d04cb1ee (patch)
tree0fcf2afd9f852c4d4c291cf8afaa2c244d598105 /dev-python/formencode/formencode-1.3.0-r3.ebuild
parent121ed4eec41fbf03e1998d09eede1bf449da63b9 (diff)
gentoo resync : 02.08.2019
Diffstat (limited to 'dev-python/formencode/formencode-1.3.0-r3.ebuild')
-rw-r--r--dev-python/formencode/formencode-1.3.0-r3.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/formencode/formencode-1.3.0-r3.ebuild b/dev-python/formencode/formencode-1.3.0-r3.ebuild
new file mode 100644
index 000000000000..6a09d0e8b3a3
--- /dev/null
+++ b/dev-python/formencode/formencode-1.3.0-r3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+
+inherit distutils-r1
+
+MY_PN="FormEncode"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="HTML form validation, generation, and conversion package"
+HOMEPAGE="http://formencode.org/ https://pypi.org/project/FormEncode/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="amd64 ~ia64 ppc ~sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="doc test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/dnspython[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pycountry[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+RESTRICT="test"
+DOCS=( docs/. )
+
+S="${WORKDIR}/${MY_P}"
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
+ sed -e '/package_data.*..docs/d' -i setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # https://github.com/formencode/formencode/issues/78
+ # 5 failures under py2.7. Although the package claims to cater to py3, the suite fails horribly
+ # Main problem is that it is written requiring to be system installed, then run.
+ # Suite found to pass on extended testing using tox.
+ nosetests || die "tests failed under ${EPYTHON}"
+}