summaryrefslogtreecommitdiff
path: root/dev-python/foolscap
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/foolscap
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/foolscap')
-rw-r--r--dev-python/foolscap/Manifest5
-rw-r--r--dev-python/foolscap/foolscap-0.11.0.ebuild53
-rw-r--r--dev-python/foolscap/foolscap-0.7.0.ebuild36
-rw-r--r--dev-python/foolscap/metadata.xml28
4 files changed, 122 insertions, 0 deletions
diff --git a/dev-python/foolscap/Manifest b/dev-python/foolscap/Manifest
new file mode 100644
index 000000000000..3dce79d33a52
--- /dev/null
+++ b/dev-python/foolscap/Manifest
@@ -0,0 +1,5 @@
+DIST foolscap-0.11.0.tar.gz 491916 BLAKE2B bf36442b4274943c00df244c2880dbf8f16b67288a6b8391c8f3e8547ab907ff6de3e1dd92e7173c5801349d1f04f3789ef1f95b5baa32dadc3c56d3dd5b5d0e SHA512 577cd15e7f9207a9675999590cb1189edbdd77a2daee5cab80d66d40b1343bcb338a064eedf372ca7f8a102ed1cef0770923d6dea27dd6c3b37c0717cdc912e8
+DIST foolscap-0.7.0.tar.gz 478999 BLAKE2B fbe3979efe8533a7727703af79aa3074f5ff54e4cd42cee4e981d8b2b73c445272792472236a52dc9fa69e9a25bd8cd30972d1fd2f37127db857ce5d5d3e7f6d SHA512 b2eb5415376d4e8e4ee3fd9ecef80a02d195d6b44059e5292c2daa7dcfdea9deafd8678ff89391128244a8d41fb6a69a92f9e4f07cc599f7358783dc8cb70f15
+EBUILD foolscap-0.11.0.ebuild 1268 BLAKE2B 17697a21cb0a1914a37105fb74358777adb430301b08be1a64aea6e3386acc2c70146ce092604b8e2fe9f5f1f81ccf575b6b41891d4aa84c7cafe4648dc32801 SHA512 8f61c6d8e2f9d8dfb5992a639f2e1ffa4441686be755dd603979887b09d335578432c5aa589d5ab07019082d141be2c29fe688ca55f19bc226c1c7b380742620
+EBUILD foolscap-0.7.0.ebuild 910 BLAKE2B eda252d8f8aef4648d06e3c281fbae305669142dbaf1120482c97899b003721d37545e104c3c0b0c4e52e2da476b8e61fbb91e6609c555202144afa53d69cef8 SHA512 3c181ec3d826f9e1f8c843266e5513341530e4c62533f56107d600da7da08030747c9c1710913b2d66c0fe1441e2e2b418259108ec9d360f1301428d38c2501d
+MISC metadata.xml 1272 BLAKE2B 2e8117819b9d14b123baeb54170b7e166c591af67d1d53911add7cf9cf1d7f5a1e23b00a4f32792d3109750a474c97341ae4d57db400c4884e2c212bfaea1547 SHA512 5509a54a69ca4d5c6898cdf125fc62d974b494dcce9117e9c66fc2e4e17b7f0d07e423739c9ea8b81cd2b3f16012400df9f764a5e2a4ab939edb2f8a3428ced0
diff --git a/dev-python/foolscap/foolscap-0.11.0.ebuild b/dev-python/foolscap/foolscap-0.11.0.ebuild
new file mode 100644
index 000000000000..e096ba770f6f
--- /dev/null
+++ b/dev-python/foolscap/foolscap-0.11.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="RPC protocol for Twisted"
+HOMEPAGE="http://foolscap.lothar.com/trac https://pypi.org/project/foolscap/"
+SRC_URI="http://${PN}.lothar.com/releases/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc +ssl test"
+
+# setup.py stipulates >=twisted-core-2.5.0 but failures occur in testsuite under -15.x
+RDEPEND="
+ dev-python/twisted-core[${PYTHON_USEDEP}]
+ dev-python/twisted-web[${PYTHON_USEDEP}]
+ dev-python/service_identity[${PYTHON_USEDEP}]
+ ssl? ( dev-python/pyopenssl[${PYTHON_USEDEP}] )
+ "
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )"
+
+python_test() {
+ trial ${PN} || die "Tests fail for ${EPYTHON}"
+}
+
+python_compile_all() {
+ local i;
+ if use doc; then
+ pushd doc > /dev/null
+ mkdir build || die
+ for i in ./*.rst
+ do
+ rst2html.py $i > ./build/${i/rst/html} || die
+ done
+ popd > /dev/null
+ fi
+}
+
+python_test() {
+ trial ${PN} || die "Tests fail for ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/foolscap/foolscap-0.7.0.ebuild b/dev-python/foolscap/foolscap-0.7.0.ebuild
new file mode 100644
index 000000000000..f7f1ceaf0029
--- /dev/null
+++ b/dev-python/foolscap/foolscap-0.7.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="RPC protocol for Twisted"
+HOMEPAGE="http://foolscap.lothar.com/trac https://pypi.org/project/foolscap/"
+SRC_URI="http://${PN}.lothar.com/releases/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc +ssl test"
+
+RDEPEND=">=dev-python/twisted-core-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/twisted-web-2.5.0[${PYTHON_USEDEP}]
+ ssl? ( dev-python/pyopenssl[${PYTHON_USEDEP}] )"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )"
+
+python_test() {
+ trial ${PN} || die "Tests fail for ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use doc; then
+ dodoc doc/*.txt
+ dohtml -A py,tpl,xhtml -r doc/*
+ fi
+}
diff --git a/dev-python/foolscap/metadata.xml b/dev-python/foolscap/metadata.xml
new file mode 100644
index 000000000000..05b50f1ab47b
--- /dev/null
+++ b/dev-python/foolscap/metadata.xml
@@ -0,0 +1,28 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription>
+This is a ground-up rewrite of Perspective Broker, which itself is Twisted's
+native RPC/RMI protocol (Remote Procedure Call / Remote Method Invocation).
+If you have control of both ends of the wire, and are thus not constrained to
+use some other protocol like HTTP/XMLRPC/CORBA/etc, you might consider using
+Foolscap.
+
+Fundamentally, Foolscap allows you to make a python object in one process
+available to code in other processes, which means you can invoke its methods
+remotely. This includes a data serialization layer to convey the object
+graphs for the arguments and the eventual response, and an object reference
+system to keep track of which objects you are connecting to. It uses a
+capability-based security model, such that once you create a non-public
+object, it is only accessible to clients to whom you've given the
+(unguessable) FURL. You can of course publish world-visible objects that
+have well-known FURLs.
+</longdescription>
+ <upstream>
+ <remote-id type="pypi">foolscap</remote-id>
+ </upstream>
+</pkgmetadata>