summaryrefslogtreecommitdiff
path: root/dev-python/fonttools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /dev-python/fonttools
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'dev-python/fonttools')
-rw-r--r--dev-python/fonttools/Manifest4
-rw-r--r--dev-python/fonttools/fonttools-4.18.2.ebuild2
-rw-r--r--dev-python/fonttools/fonttools-4.21.1.ebuild55
3 files changed, 59 insertions, 2 deletions
diff --git a/dev-python/fonttools/Manifest b/dev-python/fonttools/Manifest
index b2bec7882e6d..1e9c5965aed5 100644
--- a/dev-python/fonttools/Manifest
+++ b/dev-python/fonttools/Manifest
@@ -1,3 +1,5 @@
DIST fonttools-4.18.2.tar.gz 2499129 BLAKE2B 1ae93418121942e4303e4b138b192a30195d25c87e8c6204b508cc6a5b7a87608fcde7acbb6a2e8fb3c71ea59938827dabbe1556b7edad537523f6f0b3615696 SHA512 ceec3656c674ff5c43f4dc7cdf1468ddaf5c8bbe569d865fb015a9251ac089caedcf3dcea82c93a0c367576fcd7d65451642a6ab5d3093d941aa391b50070d53
-EBUILD fonttools-4.18.2.ebuild 1384 BLAKE2B 4e8a5141288ac35e417e96cd22784c1d9642c6012032d2c320a2ece5af99e376aaa06e8c5a9fd0b37a57567d43274f852917089834944efc2d3c7dc28b970058 SHA512 6fb079544020bcfc72b51704ac2ea1da3e21dd8772e0a0fdaaf127e9ca72a154b508241de9925cc58f75388d9b01c8ae87bb8d67857cde8819e8f49245373a81
+DIST fonttools-4.21.1.tar.gz 2531249 BLAKE2B 7f507f85061c67da0003ed2c4f685b22ccf0e6c5067adb934772ef0832656bbe092d1282b30b5a40071cd3a3219f5cfd810e06e9cd3f85ddd8fa93538134c943 SHA512 8c54809ab9f39e34f482ee6b17dbf8b309e8bfa0bde783e24195c1f2949ded64591c5e79565136ec8492c0095d593db20779d3f28b933f8e40e54b610130e0f4
+EBUILD fonttools-4.18.2.ebuild 1384 BLAKE2B 5b85d8367c403fad1710a93d76e4131ccfbc9a6f2b6cbde64c8a91489825f455a160cf21f4766f28560791e8267b3c51c6db7db160fdd7de4a685831ce654908 SHA512 659f68fb7deb7735869201c3ace83ed7a6cc38e8359b3c4af860d109c8e9decafb724d1744f3ee6587737300606b89be63d4368cef2f12044217a500240137c1
+EBUILD fonttools-4.21.1.ebuild 1469 BLAKE2B d6d83b39df02d6bbf34c9c4f79c0addb55dd423a5f68ef6dee3769cefed638d4d420b85114757cf90da8d944fdf109501ff7dd282e1d5368f8f0a8fbae710eaa SHA512 99796a6165ea1cb5b25885492fe7ec67a6ffbeab14d5755dd79e4af9a2c06818904d64e792ebe8a12bc96fee20b6aea412d8fa008fe7ae1a8baae5ee4a2640cd
MISC metadata.xml 395 BLAKE2B f31a990237241b04b7e3222093c878d57d990ee97466160947d4c85a5798543a76c480b01a8f1da13057773b3b6b6dc270d039a4211d7d5cde8991bfa9b7632c SHA512 6c676733e48ceab4d6dcc56359c62d610728e06e7483648d410cbb0826c603521823a0f73b6d832b0f90b3e2f6254a92195e751867e16fbdef8335bbb0bec430
diff --git a/dev-python/fonttools/fonttools-4.18.2.ebuild b/dev-python/fonttools/fonttools-4.18.2.ebuild
index fe67a350af5b..d0292f5917e4 100644
--- a/dev-python/fonttools/fonttools-4.18.2.ebuild
+++ b/dev-python/fonttools/fonttools-4.18.2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..8} )
+PYTHON_COMPAT=( python3_{7..9} )
PYTHON_REQ_USE="xml(+)"
DISTUTILS_USE_SETUPTOOLS=rdepend
diff --git a/dev-python/fonttools/fonttools-4.21.1.ebuild b/dev-python/fonttools/fonttools-4.21.1.ebuild
new file mode 100644
index 000000000000..6627fc915f27
--- /dev/null
+++ b/dev-python/fonttools/fonttools-4.21.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_REQ_USE="xml(+)"
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Library for manipulating TrueType, OpenType, AFM and Type1 fonts"
+HOMEPAGE="https://github.com/fonttools/fonttools/"
+SRC_URI="https://github.com/fonttools/fonttools/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+RESTRICT="!test? ( test )"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+
+ >=dev-python/fs-2.4.9[${PYTHON_USEDEP}]
+ app-arch/brotli[python,${PYTHON_USEDEP}]
+ app-arch/zopfli
+ )"
+
+python_prepare_all() {
+ # When dev-python/pytest-shutil is installed, we get weird import errors.
+ # This is due to incomplete nesting in the Tests/ tree:
+ #
+ # Tests/feaLib/__init__.py
+ # Tests/ufoLib/__init__.py
+ # Tests/svgLib/path/__init__.py
+ # Tests/otlLib/__init__.py
+ # Tests/varLib/__init__.py
+ #
+ # This tree requires an __init__.py in Tests/svgLib/ too, bug #701148.
+ touch Tests/svgLib/__init__.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+src_test() {
+ # virtualx used when matplotlib is installed causing plot module tests to run
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ pytest -vv Tests fontTools || die "Tests failed with ${EPYTHON}"
+}