summaryrefslogtreecommitdiff
path: root/dev-python/fonttools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-29 23:38:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-29 23:38:29 +0100
commita55dc4dc2b72859e439db575f57f02ce4ba700f1 (patch)
treef1d396ba3bc3ed0d2e420132606e3b704048f22e /dev-python/fonttools
parentca2977e80c0b29d0e6ce6ff178b6e0043442262b (diff)
gentoo auto-resync : 29:09:2023 - 23:38:29
Diffstat (limited to 'dev-python/fonttools')
-rw-r--r--dev-python/fonttools/Manifest2
-rw-r--r--dev-python/fonttools/fonttools-4.43.0.ebuild68
2 files changed, 70 insertions, 0 deletions
diff --git a/dev-python/fonttools/Manifest b/dev-python/fonttools/Manifest
index f05022a0e60d..d893bb0ef4cf 100644
--- a/dev-python/fonttools/Manifest
+++ b/dev-python/fonttools/Manifest
@@ -1,5 +1,7 @@
DIST fonttools-4.42.0.gh.tar.gz 3764057 BLAKE2B ef6340a58d1b8dc0fa87a6514792da76c63ee39fa7c0f420e637bb008ae4d6078722b695625bbba72481bfb47f239cd734288b6f5f89d57fcb1acca1e732f460 SHA512 c5b6963d420dd8bf2bae776880bf23c9e91aeb04f62fb3231cfb0af00008b82a19814138311c2b06cc8df1dbb83c0cd1fc1312a540918a3727407cee81d19116
DIST fonttools-4.42.1.gh.tar.gz 3767442 BLAKE2B 902eb47cfea3c113cab7e6ccf9a0b768782bd7243690cafdde9c6c76f057bc425fd17b0c1e62a43b0c40c2c26969ead1fc9e842a8dca74f063a29c3333f9250f SHA512 0bf48873c3fb8389851de44425f7b949b1de4ae7d2f46b5041225890ce3b853351f69b0d22cb647090568947b4f09ccd4450d022fd918d92ddd0dd9325397100
+DIST fonttools-4.43.0.gh.tar.gz 3767455 BLAKE2B 1c58f9d5611af9f3ee68218958a7188268207055702641bbb6505895b89c3f8cf34f285a7fcd40bf8d9ea079e05da1642a52a6f55512851322995e42e77f881d SHA512 631e7458ec7849a98b2ccb0e4ad46e6bc5bfd6206f7d478308d08348713c2ae8b63a201c19f1080427b1f377143bd930f591ee376cc573de3dea2ba4dcb7ba08
EBUILD fonttools-4.42.0.ebuild 1584 BLAKE2B 617e89d0213bd81dd88a0ab73504aabc3aed32ed0696e5cfb4ad31e4bddf24c15926ac5b1c0cc45f10cce0a9b81a7f6d0a9121f93e58d7aae69b3f8a00c56cf3 SHA512 e96f2358f4486777bbd4bba1ad094e1f0b449e7bb20277e7825dbe7aff2ecdfc6eb1c4358cdc4abfec30aaa28e960678a938eadbce6f8e4f39d9a51849f97b76
EBUILD fonttools-4.42.1.ebuild 1628 BLAKE2B 9c385ca76518d835d5c4362de304667e37bd8aa0b7fbdc9aa71ed54616502b8f63945c3c2f9afcb63e4728342b8b423251f9857e620dd8b3c6d9d680c7f698df SHA512 ef4efd7b22cd630668feca079196e3ee9b8618b3f84bff7bbc435469b1a49c647679431057e26a52bd779dcfde54ea92ac3e10248371d3ab748dfaff1f43658f
+EBUILD fonttools-4.43.0.ebuild 1635 BLAKE2B 55ce9093304a557ba894afdd3ad17daac2e1708e535ebea587726eca9aeddfd434b0d8c2fc1ff47abdd4debe9b2e7da506760944499a6ca1f62afe20de19e5a1 SHA512 5ee2c843587208ca9d5b9d88c88dd7db7571c0526102571360f61b4f7368b305872f5b5e701df4555d64a92ee156528791db89216c67fe464dba13769c25d866
MISC metadata.xml 372 BLAKE2B 950ec78bf127250847c6513c22a5108b251afdb000d361068edf9d00d64a5baf6925ba4058bb889724febb28d92abc044c29af5936a48d8e8951b12314b64357 SHA512 03e76e28959bab83fe41c3ee4b55692ced9b1360e73e38a6e8f6e5c06fd1185dcbe0214aea2edff18d248abf252c1877d0d2c2b78b8e088e606c09c34e93e7ac
diff --git a/dev-python/fonttools/fonttools-4.43.0.ebuild b/dev-python/fonttools/fonttools-4.43.0.ebuild
new file mode 100644
index 000000000000..a65b02e28c6a
--- /dev/null
+++ b/dev-python/fonttools/fonttools-4.43.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Library for manipulating TrueType, OpenType, AFM and Type1 fonts"
+HOMEPAGE="
+ https://github.com/fonttools/fonttools/
+ https://pypi.org/project/fonttools/
+"
+SRC_URI="
+ https://github.com/fonttools/fonttools/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ >=dev-python/fs-2.4.9[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ app-arch/brotli[python,${PYTHON_USEDEP}]
+ app-arch/zopfli
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # When dev-python/pytest-shutil is installed, we get weird import errors.
+ # This is due to incomplete nesting in the Tests/ tree:
+ #
+ # Tests/feaLib/__init__.py
+ # Tests/ufoLib/__init__.py
+ # Tests/svgLib/path/__init__.py
+ # Tests/otlLib/__init__.py
+ # Tests/varLib/__init__.py
+ #
+ # This tree requires an __init__.py in Tests/svgLib/ too, bug #701148.
+ touch Tests/svgLib/__init__.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+src_configure() {
+ export FONTTOOLS_WITH_CYTHON=1
+}
+
+src_test() {
+ # virtualx used when matplotlib is installed causing plot module tests to run
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest Tests fontTools || die "Tests failed with ${EPYTHON}"
+}