summaryrefslogtreecommitdiff
path: root/dev-python/fonttools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-26 00:07:28 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-26 00:07:28 +0100
commit994fe442814c4d169bb0f1ee9745604928006b39 (patch)
tree630f10f7414f44018095dd9d3cf9df55852a9d41 /dev-python/fonttools
parentf8999218b5a6eafa151e7367030cbfdb69e045ed (diff)
gentoo auto-resync : 26:05:2024 - 00:07:27
Diffstat (limited to 'dev-python/fonttools')
-rw-r--r--dev-python/fonttools/Manifest2
-rw-r--r--dev-python/fonttools/fonttools-4.52.1.ebuild99
2 files changed, 101 insertions, 0 deletions
diff --git a/dev-python/fonttools/Manifest b/dev-python/fonttools/Manifest
index 329dbfc3641f..41f8e66a1fcf 100644
--- a/dev-python/fonttools/Manifest
+++ b/dev-python/fonttools/Manifest
@@ -1,5 +1,7 @@
DIST fonttools-4.50.0.gh.tar.gz 3823676 BLAKE2B ebcc19b3f2c8367147c7e05a514951d25497b1e6e224226e0831f566464b6d407e6a52a3b30620dbe87df1a0ce03d95cb5769cab15ee78822d218ccd81419263 SHA512 a169f18077f2c4f0ad8a46569a30b3e35ca2343e9f3d43cd362dafa26085f545dd9a42e7edb3054f9d37e1576117aa34a0c2b4adabc9fc29c076e69d3fdd66ee
DIST fonttools-4.51.0.gh.tar.gz 3826324 BLAKE2B 84485874ce373ef759746104f8c0593d63e2955427a1606404e56ae006342fef39e3fe9468d85b974741ae26a8cceba23ea46e33fff0e2648c154074b01b5eac SHA512 3a9984b56a8ed1e918781c8503dd8901276ae7e20659777ff0a9bf799a42b4ec112a6cfd31deb81f73f7f19c03145a66962187fb243b2580db9d3ef7011d3d82
+DIST fonttools-4.52.1.gh.tar.gz 3845345 BLAKE2B c987e8214d4ca998b4f700d11d5c2e31efd8684f4dda6541735db9bd7547b738a1cb786b6c84aa30488a5a6fb2d71e4246dff7f873fdc1161745f74bcc29bd40 SHA512 4bb5fbcbb108723ffeb07baa87699e664775d52653aadae5ee15ed3a74d7f6349e1972e3873f3041fba6d68144f5a364b86373f158f6574a03e68e0eef4ffc7d
EBUILD fonttools-4.50.0.ebuild 2464 BLAKE2B 29ca95c136616778810dafcebe6fc0b39b81bae3f858129cdc49e4710355d725b4a50616c4ab6ff237c5cc54b4abe244a3ac1383382a1a91c6c8296a42566ad9 SHA512 c305e19e347b2caa371b313f5569caaabe63b453c5a41cfcc98f437784e19622b50a947c1be1e96664a9a9ff2668c58fee63915beec5d16bc59b53caa2dbea3e
EBUILD fonttools-4.51.0.ebuild 2465 BLAKE2B 6ba21a98a8ea8e477435431663617aed149bc79336a5a9dd0baa8555f8425443ab72980c72c5a74d7cc8939c9e9185919b27162f33499813f28a1985d21e97d0 SHA512 c47184167eb882313e26041a5f2ed888217a1b47734d21d4fff858f0197a211779e92a273ed001144d180de94be1be15d4b234d83b7fb4fb6492f84d20c25053
+EBUILD fonttools-4.52.1.ebuild 2443 BLAKE2B 52ed3636bb061e2bd1f74eb74c6e7c79fbd00d1a9914b390301fa42b18db03af7e16df88cb5d71bb611a53bfc5012466594637aaf43dcfce16283861940df0af SHA512 d5688e3bab2ebd4d0f0bef44a134ee399db6fc244467949bdfbdd720b564c4ee2c5957aad6780129fca44d470dd232de6f84559fa63c82a6a7272e909d4ab7e0
MISC metadata.xml 372 BLAKE2B 950ec78bf127250847c6513c22a5108b251afdb000d361068edf9d00d64a5baf6925ba4058bb889724febb28d92abc044c29af5936a48d8e8951b12314b64357 SHA512 03e76e28959bab83fe41c3ee4b55692ced9b1360e73e38a6e8f6e5c06fd1185dcbe0214aea2edff18d248abf252c1877d0d2c2b78b8e088e606c09c34e93e7ac
diff --git a/dev-python/fonttools/fonttools-4.52.1.ebuild b/dev-python/fonttools/fonttools-4.52.1.ebuild
new file mode 100644
index 000000000000..fdc8e4ef6bb6
--- /dev/null
+++ b/dev-python/fonttools/fonttools-4.52.1.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Library for manipulating TrueType, OpenType, AFM and Type1 fonts"
+HOMEPAGE="
+ https://github.com/fonttools/fonttools/
+ https://pypi.org/project/fonttools/
+"
+SRC_URI="
+ https://github.com/fonttools/fonttools/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~s390 ~x86"
+IUSE="+native-extensions"
+
+RDEPEND="
+ >=dev-python/fs-2.4.9[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ native-extensions? (
+ $(python_gen_cond_dep '
+ dev-python/cython[${PYTHON_USEDEP}]
+ ' 'python*')
+ )
+ test? (
+ dev-python/brotlicffi[${PYTHON_USEDEP}]
+ dev-python/munkres[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ app-arch/zopfli
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # When dev-python/pytest-shutil is installed, we get weird import errors.
+ # This is due to incomplete nesting in the Tests/ tree:
+ #
+ # Tests/feaLib/__init__.py
+ # Tests/ufoLib/__init__.py
+ # Tests/svgLib/path/__init__.py
+ # Tests/otlLib/__init__.py
+ # Tests/varLib/__init__.py
+ #
+ # This tree requires an __init__.py in Tests/svgLib/ too, bug #701148.
+ touch Tests/svgLib/__init__.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ local -x FONTTOOLS_WITH_CYTHON=$(usex native-extensions)
+ [[ ${EPYTHON} == pypy3 ]] && FONTTOOLS_WITH_CYTHON=0
+ distutils-r1_python_compile
+}
+
+src_test() {
+ # virtualx used when matplotlib is installed causing plot module tests to run
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # flaky test
+ Tests/ttLib/woff2_test.py::WOFF2ReaderTest::test_get_normal_tables
+ )
+
+ if [[ ${EPYTHON} == pypy3 ]] &&
+ has_version "dev-python/pyxattr[${PYTHON_USEDEP}]" &&
+ {
+ has_version "<dev-python/pypy3_10-exe-7.3.13_p2" ||
+ has_version "<dev-python/pypy3_10-exe-bin-7.3.13_p2"
+ }
+ then
+ EPYTEST_DESELECT+=(
+ # affected by a bug in PyPy/pyxattr
+ # https://github.com/iustin/pyxattr/issues/41
+ Tests/t1Lib/t1Lib_test.py::ReadWriteTest::test_read_with_path
+ )
+ fi
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ nonfatal epytest \
+ -p rerunfailures --reruns=5 \
+ Tests fontTools || die -n "Tests failed with ${EPYTHON}"
+}