summaryrefslogtreecommitdiff
path: root/dev-python/fonttools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-11 11:46:23 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-11 11:46:23 +0100
commit2046683958d0497bec1458741dc867558b69e622 (patch)
tree7e3b4eb74040f3fb955d11fe2db0ef9da77af912 /dev-python/fonttools
parent980af9d76d4b7d7541b41eeff427e5cbd5cf7ec3 (diff)
gentoo auto-resync : 11:05:2023 - 11:46:23
Diffstat (limited to 'dev-python/fonttools')
-rw-r--r--dev-python/fonttools/Manifest2
-rw-r--r--dev-python/fonttools/fonttools-4.39.4.ebuild67
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/fonttools/Manifest b/dev-python/fonttools/Manifest
index d8dc576fc3d9..df0dda8128b7 100644
--- a/dev-python/fonttools/Manifest
+++ b/dev-python/fonttools/Manifest
@@ -1,3 +1,5 @@
DIST fonttools-4.39.3.gh.tar.gz 3694939 BLAKE2B c2a758c226651866aecae198fe31dab20ff7ed2f67cfe2157eebc0c2254b537e711c5a190fc29c259326ded0d82e54801fed8caada0003a4e9e6e1b24bdc00a7 SHA512 84e7435308311cc8d8814dd54d6de4e863d9490d7214d981c372cf6d811dc5802c24b9dd9815c1b12bc1acdbb2e1b2075dac6308d0600f421cc1d9741d8f9410
+DIST fonttools-4.39.4.gh.tar.gz 3710610 BLAKE2B f4d75ae71c7b8ec752eee3820129719583072c8e1e68d54b3443c192e7c6732e7db7adfaec32145b87eccd23b1720a748e70682d58a1628d93f89890d3ddc274 SHA512 4be7c19022ccfbb182edb7d80ec50ff2aa91eae3dd4328c1023e65a293e079edd4c1ae0a8b2260e35fa940417e7b03dc96bd7a6d6ec4234bc4c4257187b24758
EBUILD fonttools-4.39.3.ebuild 1570 BLAKE2B 4581bd4dedf3a27f3f8e930104407915e5a6dd4e94bc0c4983276ce30de804f291d8f2885cf3951b88c214f5bf0943437e3375eaf15bf783231d3f9b004e733d SHA512 150fabfaaf2207eeca50d560b6ddb33525f69e3912916c582f8296b659cdd570d943933f463e52fa1a84558d1286ad34578869fb3633c6c635ec73c72ebc261c
+EBUILD fonttools-4.39.4.ebuild 1578 BLAKE2B 91c8c7c35f4491e251296fae9b917199b6c9db9ba0dd1d01c9cea5c3d3673239a36a57718244a302a22628feeac155e9203f2817db6c7a56c8f6247513c4615d SHA512 84adcf85f84c149e0333a0fea3ebb0d438d42d7c6a9f153000db2d3de9fe2a54c7bce73b38dfe6ece761d51eb37b0cd2a452800da2a065bcff637101eae8291e
MISC metadata.xml 372 BLAKE2B 950ec78bf127250847c6513c22a5108b251afdb000d361068edf9d00d64a5baf6925ba4058bb889724febb28d92abc044c29af5936a48d8e8951b12314b64357 SHA512 03e76e28959bab83fe41c3ee4b55692ced9b1360e73e38a6e8f6e5c06fd1185dcbe0214aea2edff18d248abf252c1877d0d2c2b78b8e088e606c09c34e93e7ac
diff --git a/dev-python/fonttools/fonttools-4.39.4.ebuild b/dev-python/fonttools/fonttools-4.39.4.ebuild
new file mode 100644
index 000000000000..6f4e61cd6a8f
--- /dev/null
+++ b/dev-python/fonttools/fonttools-4.39.4.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Library for manipulating TrueType, OpenType, AFM and Type1 fonts"
+HOMEPAGE="
+ https://github.com/fonttools/fonttools/
+ https://pypi.org/project/fonttools/
+"
+SRC_URI="
+ https://github.com/fonttools/fonttools/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/fs-2.4.9[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ app-arch/brotli[python,${PYTHON_USEDEP}]
+ app-arch/zopfli
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # When dev-python/pytest-shutil is installed, we get weird import errors.
+ # This is due to incomplete nesting in the Tests/ tree:
+ #
+ # Tests/feaLib/__init__.py
+ # Tests/ufoLib/__init__.py
+ # Tests/svgLib/path/__init__.py
+ # Tests/otlLib/__init__.py
+ # Tests/varLib/__init__.py
+ #
+ # This tree requires an __init__.py in Tests/svgLib/ too, bug #701148.
+ touch Tests/svgLib/__init__.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+src_configure() {
+ export FONTTOOLS_WITH_CYTHON=1
+}
+
+src_test() {
+ # virtualx used when matplotlib is installed causing plot module tests to run
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ epytest Tests fontTools || die "Tests failed with ${EPYTHON}"
+}