summaryrefslogtreecommitdiff
path: root/dev-python/flufl-lock/flufl-lock-6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/flufl-lock/flufl-lock-6.0.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/flufl-lock/flufl-lock-6.0.ebuild')
-rw-r--r--dev-python/flufl-lock/flufl-lock-6.0.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-python/flufl-lock/flufl-lock-6.0.ebuild b/dev-python/flufl-lock/flufl-lock-6.0.ebuild
deleted file mode 100644
index 365c8d1b0d42..000000000000
--- a/dev-python/flufl-lock/flufl-lock-6.0.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-MY_P=${P/-/.}
-DESCRIPTION="NFS-safe file locking with timeouts for POSIX systems"
-HOMEPAGE="https://gitlab.com/warsaw/flufl.lock"
-SRC_URI="mirror://pypi/${PN::1}/${PN/-/.}/${MY_P}.tar.gz"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- dev-python/atpublic[${PYTHON_USEDEP}]
- dev-python/psutil[${PYTHON_USEDEP}]"
-BDEPEND="
- test? ( dev-python/sybil[${PYTHON_USEDEP}] )"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- sed -i -e 's:--cov=flufl --cov-report=term --cov-report=xml::' \
- setup.cfg || die
- distutils-r1_src_prepare
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- find "${D}" -name '*.pth' -delete || die
-}