summaryrefslogtreecommitdiff
path: root/dev-python/flufl-lock/flufl-lock-3.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-15 17:25:28 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-15 17:25:28 +0000
commit6b933047f46efec1aa747570f945344254227457 (patch)
treea12a4b87b38f954c4de435272cf4b90d721df5e8 /dev-python/flufl-lock/flufl-lock-3.2.ebuild
parentf45955e60d4da9b7f4a1088c98042f9c06669039 (diff)
gentoo resync : 15.12.2017
Diffstat (limited to 'dev-python/flufl-lock/flufl-lock-3.2.ebuild')
-rw-r--r--dev-python/flufl-lock/flufl-lock-3.2.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/flufl-lock/flufl-lock-3.2.ebuild b/dev-python/flufl-lock/flufl-lock-3.2.ebuild
new file mode 100644
index 000000000000..d757bbabce0a
--- /dev/null
+++ b/dev-python/flufl-lock/flufl-lock-3.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_4 python3_5 python3_6 )
+inherit distutils-r1
+
+MY_PN=${PN/-/.}
+
+DESCRIPTION="NFS-safe file locking with timeouts for POSIX systems."
+HOMEPAGE="https://gitlab.com/warsaw/flufl.lock"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/atpublic[${PYTHON_USEDEP}]"