summaryrefslogtreecommitdiff
path: root/dev-python/flit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-21 00:15:53 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-21 00:15:53 +0000
commitdb653baf275126269bb89ea0d2bdb8e50497a94c (patch)
tree9d1ee94cfa7312384acd366d3dd8f629660b3f18 /dev-python/flit
parent1534d50aaf24272ec425fa439389ef7e1f7bf174 (diff)
gentoo auto-resync : 21:02:2025 - 00:15:53
Diffstat (limited to 'dev-python/flit')
-rw-r--r--dev-python/flit/Manifest2
-rw-r--r--dev-python/flit/flit-3.11.0.ebuild57
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/flit/Manifest b/dev-python/flit/Manifest
index 374522c22ab2..fcb470b34195 100644
--- a/dev-python/flit/Manifest
+++ b/dev-python/flit/Manifest
@@ -1,3 +1,5 @@
DIST flit-3.10.1.tar.gz 143162 BLAKE2B d98c18a161380c2eb605083a700d7f5226fdc08f72defe9fd60cc8dba5947e9904d4a4df05a9620ef2fcbef8c4913f596b19ef365df7614c4fba7434acc764fd SHA512 37ff7e4de10d4b123cee854e692511574748a050d177e50f06330223ae94a4347e358ff07ca9545c3c8346c51c6734227808929f59401fdd062498d6bf69209a
+DIST flit-3.11.0.tar.gz 153236 BLAKE2B b06660e1b57279b0d855dad6116e25115c9c52eae5fb8654b79608661affff8e98a2aaf011c0cb4eb940047a6d219825382e3db6266a6a1cc919bb16c6fadf67 SHA512 704774ab9b8154056a82f59814c2589ad4b3c8593a8e0de75eae99b1517211790604988efaf4f32e5f49fd472ec00efe8269b72524f285a647f4b8126699a4b7
EBUILD flit-3.10.1.ebuild 1409 BLAKE2B 7575d28e1856f62482e7f77547f60d9b9e0ac31844c8483520f3f30e1713fc97b38d7faefc5b2140d2bb2ee2e2c44d4625b11a22527ce98f8e2bf981a74d471e SHA512 0797d3977bddc784ca234b4033db672da49e656dcaf3a83fa54bce81c7660c9ddfa63e62798b7fc8f36f1e692e367ab2d346906dd2286427e0705b91fa8fc9cd
+EBUILD flit-3.11.0.ebuild 1409 BLAKE2B ef0eca19607e9f2f86c70ab0d5db8d441dd8ad229dac93341c149f563e2ec435b6f3acbeb495246fc214f5e7f378021dee1e78b48bd37d76c5d3765d6db9fd6a SHA512 96283ac6a181b4af16751df964157781b99f4a53fe90a8420e99ea6516a9924bb8be682b0202e631541ed38a83089bc7f2f35ad3bef863c20f1d1a2178060ba1
MISC metadata.xml 467 BLAKE2B 534a82783fa3ff1642fc8400689549e75223fa01b175f4ac164d4a636a4c9eaef5bdd9fdd339ffc30239436449788b4d01ebc5e3609034d440c01a5c699176ea SHA512 ad8f3f98a35aa88255bafa81ea9cb109e14b8a544b053cff3f1325dfda3c4c6343a5060353c43a08e030e80a60186eb7dae248d7f6739ea95a7e72e747b1b194
diff --git a/dev-python/flit/flit-3.11.0.ebuild b/dev-python/flit/flit-3.11.0.ebuild
new file mode 100644
index 000000000000..73330b02dda8
--- /dev/null
+++ b/dev-python/flit/flit-3.11.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 2019-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Simplified packaging of Python modules"
+HOMEPAGE="
+ https://github.com/pypa/flit/
+ https://flit.readthedocs.io/
+ https://pypi.org/project/flit/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86"
+
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ >=dev-python/flit-core-${PV}[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/tomli-w[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}
+ sys-apps/grep
+ test? (
+ dev-python/responses[${PYTHON_USEDEP}]
+ dev-python/testpath[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_DESELECT=(
+ # requires Internet
+ tests/test_config.py::test_invalid_classifier
+ # failing due to Gentoo pip patches
+ tests/test_install.py::InstallTests::test_install_data_dir
+ tests/test_install.py::InstallTests::test_install_module_pep621
+ tests/test_install.py::InstallTests::test_symlink_data_dir
+ tests/test_install.py::InstallTests::test_symlink_module_pep621
+)
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc \
+ dev-python/sphinxcontrib-github-alt \
+ dev-python/pygments-github-lexers \
+ dev-python/sphinx-rtd-theme
+
+src_prepare() {
+ # make sure system install is used
+ rm -r flit_core || die
+ distutils-r1_src_prepare
+}