summaryrefslogtreecommitdiff
path: root/dev-python/flit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-04 00:00:19 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-04 00:00:19 +0100
commit7f3fecbb5b871825fe9632f46659869cab6a3769 (patch)
treedd2be4fe7ee3475ca4ad093698f0f8fd1e0965dc /dev-python/flit
parenta98588cfddf3d6e88a5f17d7f399b695163c7a85 (diff)
gentoo auto-resync : 04:05:2024 - 00:00:19
Diffstat (limited to 'dev-python/flit')
-rw-r--r--dev-python/flit/Manifest2
-rw-r--r--dev-python/flit/flit-3.9.0.ebuild54
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/flit/Manifest b/dev-python/flit/Manifest
index e2f80b125d70..131f25651fff 100644
--- a/dev-python/flit/Manifest
+++ b/dev-python/flit/Manifest
@@ -1,3 +1,5 @@
DIST flit-3.8.0.tar.gz 139496 BLAKE2B 85ee9fb13af35bf6716713bd7cf3f5893cd729826ad362aa5ec22077f9b4d16db4d785f183dee37c725b771188f31f2cf38c8e4aedc3af25a3efdc8ff1460bc6 SHA512 08170ee710857fcbfc1f72dbb94c535d70a2477c7598eacacc9a0e2f90f4fe11f4d910f1fcc11de210a6b50d89049e5835127090c6acabb00c69a821919e68cc
+DIST flit-3.9.0.tar.gz 141104 BLAKE2B 4ca268c49a34817756dea5fe7d2bd2fa15fe8f4247bcdea50765d56c43fd9c89292f45ae2a68d6f210d994ed1bce159121aba02e769f22940c548baf3e212afe SHA512 3cbca4530fe463e27fb43130e0d00681e63434bdd552bd61b4a2f3b7967729d9d9a49c69b1a2380ed99bcca1e66a38e592f41cbe38a471d3e7297ab00cdabc29
EBUILD flit-3.8.0.ebuild 1455 BLAKE2B 3fdfbeeca3d9f139a27b9121d53e478bbd09226138bc3d4465aca4cfcd9241d1a709e028176bfe3e5845cf084425f9ce7665b57aabebd08e2eb5b537edae452a SHA512 9965a8da95dab82663d6667f60537b5a9c9ba38a57cc51c9ac9a7642b4012749f7cf45218c1b5bf899bee792592696501857623ee362b8761aca25b440afa739
+EBUILD flit-3.9.0.ebuild 1456 BLAKE2B 41561b32fe219368e1be7b66f282fc3776878c52138130f535ba8a0264f8da08446bee47441114a9d26892c9904151bba2d2cefabd3481d64eb5b549f6601aa5 SHA512 b4675a29a4608eef04a6eb94750f0a0dee33d4bf787b7adfd52961af442fcd88c8a7760777d504d9970d5aa6c2a7a0368384ae081b344891dee5170127bf4136
MISC metadata.xml 467 BLAKE2B 534a82783fa3ff1642fc8400689549e75223fa01b175f4ac164d4a636a4c9eaef5bdd9fdd339ffc30239436449788b4d01ebc5e3609034d440c01a5c699176ea SHA512 ad8f3f98a35aa88255bafa81ea9cb109e14b8a544b053cff3f1325dfda3c4c6343a5060353c43a08e030e80a60186eb7dae248d7f6739ea95a7e72e747b1b194
diff --git a/dev-python/flit/flit-3.9.0.ebuild b/dev-python/flit/flit-3.9.0.ebuild
new file mode 100644
index 000000000000..249a8b03166e
--- /dev/null
+++ b/dev-python/flit/flit-3.9.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+inherit distutils-r1 pypi
+
+DESCRIPTION="Simplified packaging of Python modules"
+HOMEPAGE="https://github.com/pypa/flit https://flit.readthedocs.io/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86"
+
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ >=dev-python/flit-core-${PV}[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests_download[${PYTHON_USEDEP}]
+ dev-python/tomli[${PYTHON_USEDEP}]
+ dev-python/tomli-w[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}
+ sys-apps/grep
+ test? (
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ dev-python/testpath[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_DESELECT=(
+ # requires Internet
+ tests/test_config.py::test_invalid_classifier
+ # failing due to Gentoo pip patches
+ tests/test_install.py::InstallTests::test_install_data_dir
+ tests/test_install.py::InstallTests::test_install_module_pep621
+ tests/test_install.py::InstallTests::test_symlink_data_dir
+ tests/test_install.py::InstallTests::test_symlink_module_pep621
+)
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc \
+ dev-python/sphinxcontrib-github-alt \
+ dev-python/pygments-github-lexers \
+ dev-python/sphinx-rtd-theme
+
+src_prepare() {
+ # make sure system install is used
+ rm -r flit_core || die
+ distutils-r1_src_prepare
+}