summaryrefslogtreecommitdiff
path: root/dev-python/flexx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/flexx
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/flexx')
-rw-r--r--dev-python/flexx/Manifest5
-rw-r--r--dev-python/flexx/flexx-0.3.1.ebuild25
-rw-r--r--dev-python/flexx/flexx-0.4.1.ebuild24
-rw-r--r--dev-python/flexx/metadata.xml16
4 files changed, 70 insertions, 0 deletions
diff --git a/dev-python/flexx/Manifest b/dev-python/flexx/Manifest
new file mode 100644
index 000000000000..0aa11d4411a8
--- /dev/null
+++ b/dev-python/flexx/Manifest
@@ -0,0 +1,5 @@
+DIST flexx-0.3.1.zip 418280 BLAKE2B 9b0d5e91b7a0c61c2b7c65594546531f7f611620d20fbe1ad487f7f8db104d106d75c2818364658901ce7133f3676f8274cea5946b9525a9f6b6f4f4fdd8c64f SHA512 3d98daa18e0f307ed24386fc59a59a4df1727cdc7483cb1fa7bc6c5b2eb8cba36fbc100a98d8549ac890ef8ba86b9acef77d34e26c99994b918f5344354b0bfd
+DIST flexx-0.4.1.tar.gz 287596 BLAKE2B 768100f6ed38ea7639e79c23a74a2ba38c41e4450920be4c331c159fed92ee8fd143de28c33ac7eb2625717c2fd53b90571a0a9064b36e5c9be4883d6e71468d SHA512 af9d84876d2c6b5f8b9fe7967dc282e4043456606c1574c10cfcd15a3f3d0d3f8f889a41ff254655eed06200b5d9c10fa27249343ee689ff62346031a4ed607b
+EBUILD flexx-0.3.1.ebuild 553 BLAKE2B 9d973cfd6c17563c4abf3bd2791426b72e495234c9309921c461389c8c233cded08e89c1ddebfea7e88e2611e6e7feaf1988545df3fd581d70734bf85b290238 SHA512 43409b4fc2e416d98bb27cb34821d4f28e956954703b09251597e90f09f5bd161358a7737251fa849cc66610f150e6436ee4402476fac6123670aa62d05401ef
+EBUILD flexx-0.4.1.ebuild 652 BLAKE2B f626b6e88647b013212811a8b855eb03e2e6f7531cb7961acf62247d0b951b0e5fc847d0ced6a63f1aa2346f4d5debb349f69ef616c2f9eb643fbba6df64efa9 SHA512 dc34d192bb8f828ac727883bd1e3e10eee1c3113ace957ebb36b94e156e14400784851d49189769fa9380a91801e1daf59ed15bf9a521f453c07eacbd90f6635
+MISC metadata.xml 509 BLAKE2B cae737d6d72895541b62c3aad8301bda5b44314fd46df14237061cfd260a57f524d803b7054927834b00316d1add8e28be4fdc05adcc6142a68986944e263ccc SHA512 5e15dab8c10def713dacd1e6883502c075aff68e72b839d89273d28b3edc7ad03cc82152e1f4fddbd416b08fb0efdda3df26832c99bab7cddf700caba0258492
diff --git a/dev-python/flexx/flexx-0.3.1.ebuild b/dev-python/flexx/flexx-0.3.1.ebuild
new file mode 100644
index 000000000000..ec907e211f7c
--- /dev/null
+++ b/dev-python/flexx/flexx-0.3.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure Python toolkit for creating GUI's using web technology"
+HOMEPAGE="
+ https://flexx.readthedocs.org
+ https://github.com/zoofio/flexx
+ https://pypi.org/project/flexx/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
diff --git a/dev-python/flexx/flexx-0.4.1.ebuild b/dev-python/flexx/flexx-0.4.1.ebuild
new file mode 100644
index 000000000000..2f27036efa8c
--- /dev/null
+++ b/dev-python/flexx/flexx-0.4.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure Python toolkit for creating GUI's using web technology"
+HOMEPAGE="
+ https://flexx.readthedocs.org
+ https://github.com/zoofio/flexx
+ https://pypi.org/project/flexx/"
+SRC_URI="https://github.com/zoofIO//${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~x86 ~amd64-linux ~x86-linux"
+
+#IUSE="doc test" broken tests
+IUSE=""
+RDEPEND="www-servers/tornado[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/flexx/metadata.xml b/dev-python/flexx/metadata.xml
new file mode 100644
index 000000000000..a79517c51568
--- /dev/null
+++ b/dev-python/flexx/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">flexx</remote-id>
+ <remote-id type="github">zoofIO/flexx</remote-id>
+ <maintainer status="unknown">
+ <email>almar.klein@gmail.com</email>
+ <name>Flexx contributors</name>
+ </maintainer>
+ </upstream>
+</pkgmetadata>