summaryrefslogtreecommitdiff
path: root/dev-python/flexmock/flexmock-0.10.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-21 23:14:26 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-21 23:14:26 +0100
commit7c59acba5699c9c58090a7a738669669a7307023 (patch)
treed51d27d020895a6b7a3298d9d1b9846c1fcb59a0 /dev-python/flexmock/flexmock-0.10.6.ebuild
parente2db47eaae00ec33f8971db44b68645c5d3b9590 (diff)
gentoo resync : 21.08.2021
Diffstat (limited to 'dev-python/flexmock/flexmock-0.10.6.ebuild')
-rw-r--r--dev-python/flexmock/flexmock-0.10.6.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/flexmock/flexmock-0.10.6.ebuild b/dev-python/flexmock/flexmock-0.10.6.ebuild
new file mode 100644
index 000000000000..7280fd3db06f
--- /dev/null
+++ b/dev-python/flexmock/flexmock-0.10.6.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Testing library to create mocks, stubs and fakes"
+HOMEPAGE="https://flexmock.readthedocs.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-with_args-sys.stdout.write.patch"
+)
+
+python_install_all() {
+ distutils-r1_python_install_all
+ dodoc -r docs
+}