summaryrefslogtreecommitdiff
path: root/dev-python/fleep/fleep-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-07 00:16:33 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-07 00:16:33 +0100
commitd162ba1860a88062f4cd61f8b52fc303ba0b2991 (patch)
tree24cd2cf57f3932a24b96e4a0f6666489447e43ba /dev-python/fleep/fleep-9999.ebuild
parent590b9b7b03bf4651e099949e318755af7cfa81b8 (diff)
gentoo resync : 07.08.2021
Diffstat (limited to 'dev-python/fleep/fleep-9999.ebuild')
-rw-r--r--dev-python/fleep/fleep-9999.ebuild27
1 files changed, 18 insertions, 9 deletions
diff --git a/dev-python/fleep/fleep-9999.ebuild b/dev-python/fleep/fleep-9999.ebuild
index 0171f1ef7528..68f31790d687 100644
--- a/dev-python/fleep/fleep-9999.ebuild
+++ b/dev-python/fleep/fleep-9999.ebuild
@@ -1,23 +1,32 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
-DESCRIPTION="File format determination library for Python"
-HOMEPAGE="https://github.com/floyernick/fleep-py"
-
-if [ "${PV}" = "9999" ]; then
+if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/floyernick/fleep-py.git"
inherit git-r3
else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ # upstream aren't tagging the releases, just as commit title
+ COMMIT="994bc2c274482d80ab13d89d8f7343eb316d3e44"
+ SRC_URI="https://github.com/floyernick/fleep-py/archive/${COMMIT}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/fleep-py-${COMMIT}"
+
KEYWORDS="~amd64 ~x86"
fi
+DESCRIPTION="File format determination library for Python"
+HOMEPAGE="https://github.com/floyernick/fleep-py"
+
LICENSE="MIT"
SLOT="0"
-IUSE=""
+
+python_test() {
+ cd tests || die
+ "${EPYTHON}" maintest.py || die "Tests fail with ${EPYTHON}"
+}