summaryrefslogtreecommitdiff
path: root/dev-python/flask
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-24 23:59:27 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-24 23:59:27 +0100
commitb987a550f067c3da93b0664cf1fdc8a624c0aa38 (patch)
tree9ad1767fad656d26471a81af6bac8400a1c75218 /dev-python/flask
parente3f21c8aff8a76afe3423721c437a088e9232840 (diff)
gentoo auto-resync : 24:04:2024 - 23:59:27
Diffstat (limited to 'dev-python/flask')
-rw-r--r--dev-python/flask/Manifest4
-rw-r--r--dev-python/flask/flask-3.0.2.ebuild58
-rw-r--r--dev-python/flask/flask-3.0.3.ebuild2
3 files changed, 2 insertions, 62 deletions
diff --git a/dev-python/flask/Manifest b/dev-python/flask/Manifest
index c65f95d50413..9d7363b07631 100644
--- a/dev-python/flask/Manifest
+++ b/dev-python/flask/Manifest
@@ -1,5 +1,3 @@
-DIST flask-3.0.2.tar.gz 675248 BLAKE2B 137e09ac0f3bb9d027f2c8204769ae98ae5b9992f6126961208a875efb8d450abec471859ab0341120356c9b61238700f0e918da867d7265e31e73cee3a242db SHA512 02f937dae7d654f6286eb9fcf2d68d83f3ef56dbc4d59a961ea1bd95d17fac7a5ace3f27ebb03ff0592f6a87361e59934ffda098714fc8a049a487d4c0bbc0ef
DIST flask-3.0.3.tar.gz 676315 BLAKE2B 19013ff4588dc057febe2720eadcfcadb0e1854731c2c9e391449696549106da930c11f94782610424ea40c1377e9b8aa52ca39fedc6ad0c98c9a70a56d01514 SHA512 977c0e5fd2d496fae8e34a035f211118642dc6518a14dc5f6c175b72c6a76407aeb9ff0ed1f5db636370a9aa7e0d36baa783713ea7bdabd7f28c8c2b94643cd1
-EBUILD flask-3.0.2.ebuild 1368 BLAKE2B 4656431ec3eaf18134e9150b7589b4344c628cb689cc68476773bfad9a1dd751db1a26fc337f7172baedd0cff30a838bcfb0b01a2d7418b79bb8e8bc9974beee SHA512 6fab4f186aef375ea25f5310a828efb5d38d53fba6a7def75dab9b99367b1166a206c28f487156ccb738c5b7bb83c0cf88db6bc833cd39393301906eafdaa261
-EBUILD flask-3.0.3.ebuild 1376 BLAKE2B 67626dde4c5d8307e19cfcb51eb3e871f61657ba81a7c94151be7e8ef59d07333f97da4e9d9078ec633c075c222bf7d3ed1daf8458ed35917dada1771ee9d28b SHA512 89a4f916a58ace46e78bc0cc89b8642359a9939e50b6f2ed36d01ad79bc1be22ac90d3f36b053899c1dab9cabb52209b8ad201334995bc8f208d78afaa79adfd
+EBUILD flask-3.0.3.ebuild 1368 BLAKE2B 4656431ec3eaf18134e9150b7589b4344c628cb689cc68476773bfad9a1dd751db1a26fc337f7172baedd0cff30a838bcfb0b01a2d7418b79bb8e8bc9974beee SHA512 6fab4f186aef375ea25f5310a828efb5d38d53fba6a7def75dab9b99367b1166a206c28f487156ccb738c5b7bb83c0cf88db6bc833cd39393301906eafdaa261
MISC metadata.xml 386 BLAKE2B b449c54b966bc8943f7b7b12d6126867a89a2759eb749c08f7ad53a174e93ecad07f09b5e30c8562c63ab05df75a82e2f48f550ea8cf3a546f5afc2eef5a896d SHA512 123334db31948046e47f3cdbe0237cdec3dc2207485c8243d1e34e065436995423b6a89909563a6158741a8cc62a7fdad95923870a7114cf69e58ef715e7ec5c
diff --git a/dev-python/flask/flask-3.0.2.ebuild b/dev-python/flask/flask-3.0.2.ebuild
deleted file mode 100644
index e59b6ec1d32e..000000000000
--- a/dev-python/flask/flask-3.0.2.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=flit
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="A microframework based on Werkzeug, Jinja2 and good intentions"
-HOMEPAGE="
- https://palletsprojects.com/p/flask/
- https://github.com/pallets/flask/
- https://pypi.org/project/Flask/
-"
-if [[ ${PV} == *9999* ]]; then
- EGIT_REPO_URI="https://github.com/mitsuhiko/flask.git"
- inherit git-r3
-else
- inherit pypi
- KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-fi
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="examples"
-
-RDEPEND="
- >=dev-python/blinker-1.6.2[${PYTHON_USEDEP}]
- >=dev-python/click-8.1.3[${PYTHON_USEDEP}]
- >=dev-python/itsdangerous-2.1.2[${PYTHON_USEDEP}]
- >=dev-python/jinja-3.1.2[${PYTHON_USEDEP}]
- >=dev-python/werkzeug-3.0.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- >=dev-python/asgiref-3.2[${PYTHON_USEDEP}]
- !!dev-python/shiboken2[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx docs \
- dev-python/pallets-sphinx-themes \
- dev-python/sphinx-issues \
- dev-python/sphinx-tabs \
- dev-python/sphinxcontrib-log-cabinet
-distutils_enable_tests pytest
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest
-}
-
-python_install_all() {
- use examples && dodoc -r examples
- distutils-r1_python_install_all
-}
diff --git a/dev-python/flask/flask-3.0.3.ebuild b/dev-python/flask/flask-3.0.3.ebuild
index d356436274d9..e59b6ec1d32e 100644
--- a/dev-python/flask/flask-3.0.3.ebuild
+++ b/dev-python/flask/flask-3.0.3.ebuild
@@ -19,7 +19,7 @@ if [[ ${PV} == *9999* ]]; then
inherit git-r3
else
inherit pypi
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
fi
LICENSE="BSD"