summaryrefslogtreecommitdiff
path: root/dev-python/flask
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /dev-python/flask
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'dev-python/flask')
-rw-r--r--dev-python/flask/Manifest1
-rw-r--r--dev-python/flask/files/flask-1.1.1-py38.patch38
2 files changed, 0 insertions, 39 deletions
diff --git a/dev-python/flask/Manifest b/dev-python/flask/Manifest
index 2d238eb1214c..93dfa7836478 100644
--- a/dev-python/flask/Manifest
+++ b/dev-python/flask/Manifest
@@ -1,4 +1,3 @@
-AUX flask-1.1.1-py38.patch 1134 BLAKE2B bc252d38ca5c49ac7a327b50ee62eccb26a81f041a81fb6996fba790a6ec0f11b004fe90917ef4d90238126a17bb9864f81843f41edc7e43795acfb382799482 SHA512 ce43cf60c59aa17c716802779c163231435310b1942dd02373da51658119922bd6707b910c23dea49a9727f5a6a82219893ad3918384e7ebe3b5025bb4f7a6db
DIST Flask-1.1.2.tar.gz 637516 BLAKE2B 90dffbb8faa48489d1c71ff2a064d41e97d2103c07532fd5b252dbe0b32e4babb815e31f0ceae201a66cead645b68149d13d4bb39a0df1b27b4002e613920493 SHA512 9feb6a9a8f34fadbea508d465f73c24b1d81b3f66243804dc3904d198c2fd78e2e1bef94df6a4940a7eec6b9b54abea06557a87de8b27b0a9497d18b3e071384
EBUILD flask-1.1.2.ebuild 1331 BLAKE2B c9721dad0a9e94b65f4c7b3f6b1afe645c7a0a5a8821bb5a51ba605da4ce9156186fd98c1ecfe48338510461c201fb523735e5a4383926b4bbede44e93ca9f84 SHA512 9fc78e36f192338d60fcced3d749de5030a28a8a0137d2c605c4cfb7fcd9829c1d6614dc6894f5a5544f3e5d21beddfa4002785e06665f13cfa247d863da021b
EBUILD flask-9999.ebuild 1306 BLAKE2B 624eabc5bd3dc1dc8470f04b49c65a3dfd9ea1ea72e75fbbdb4130cb5e5790e299f4309f4088ba3e9cd13a8c2400c6bac405515b7c3b01b3963b21d33fb6067d SHA512 af1a02401a2b305f0579dddbfa5f5430df4a04b9309e704ba9bab37449f06894a6c4f7b6f2e1c1e7e7d1a0330cc8d36b1dee8ac5a7baa8cb3aa22b910b742498
diff --git a/dev-python/flask/files/flask-1.1.1-py38.patch b/dev-python/flask/files/flask-1.1.1-py38.patch
deleted file mode 100644
index a03aa445137b..000000000000
--- a/dev-python/flask/files/flask-1.1.1-py38.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-commit c367a86cc5be70da4928b276d0218f98df6e854d
-Author: Fernanda GuimarĂ£es <fernandaguimaraes28@gmail.com>
-Date: Mon Oct 28 21:37:25 2019 -0300
-
- Test test_send_from_directory_bad_request no longer fails in Python 3.8.
-
-diff --git a/tests/test_helpers.py b/tests/test_helpers.py
-index 78a56221..21735af1 100644
---- a/tests/test_helpers.py
-+++ b/tests/test_helpers.py
-@@ -11,6 +11,7 @@
- import datetime
- import io
- import os
-+import sys
- import uuid
-
- import pytest
-@@ -780,12 +781,17 @@ class TestSendfile(object):
- assert rv.data.strip() == b"Hello Subdomain"
- rv.close()
-
-- def test_send_from_directory_bad_request(self, app, req_ctx):
-+ def test_send_from_directory_null_character(self, app, req_ctx):
- app.root_path = os.path.join(
- os.path.dirname(__file__), "test_apps", "subdomaintestmodule"
- )
-
-- with pytest.raises(BadRequest):
-+ if sys.version_info >= (3, 8):
-+ exception = NotFound
-+ else:
-+ exception = BadRequest
-+
-+ with pytest.raises(exception):
- flask.send_from_directory("static", "bad\x00")
-
-