summaryrefslogtreecommitdiff
path: root/dev-python/flask
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-22 21:47:11 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-22 21:47:11 +0100
commit9368ace94caa5cdda868a0dbb7c75a3fc7a2b911 (patch)
treea9a5e87e053b6853c703732ad8050bd895efc1ea /dev-python/flask
parentc1d361b300cff921a04bd9ae2f800bf8914559eb (diff)
gentoo auto-resync : 22:08:2023 - 21:47:11
Diffstat (limited to 'dev-python/flask')
-rw-r--r--dev-python/flask/Manifest4
-rw-r--r--dev-python/flask/flask-2.3.2.ebuild7
-rw-r--r--dev-python/flask/flask-2.3.3.ebuild57
3 files changed, 60 insertions, 8 deletions
diff --git a/dev-python/flask/Manifest b/dev-python/flask/Manifest
index 2d4579d69add..a4a232ed7250 100644
--- a/dev-python/flask/Manifest
+++ b/dev-python/flask/Manifest
@@ -1,3 +1,5 @@
DIST Flask-2.3.2.tar.gz 686251 BLAKE2B d81553b100e88ab79218422d6d39bb8b186f436c3729985504d1f54536b5e0f783509dcfbf0791890e7c03928131ddd4b8894db51f27e4075c50248ebd7846a2 SHA512 7917c3658a1dec77decad2dbc067a1ae602a66007573f1ff26527c214dede2c455ca5e6490159922fac967ceea99bd880cf929d05e21ed49b08abf501d96e8f8
-EBUILD flask-2.3.2.ebuild 1524 BLAKE2B 2f1183a3bc5f7b78de6086b792041240c65842e07162142773cfea773000d4d9ffb14ac53bff6943c31ea3e68734f8828409fc7058e68d663c6cee2e2788d758 SHA512 1793f66e1180a2cb65328a02c1c1d7d8d5739432f795c5ca8257a7ee527091a31d172c1e5fb9c8591a82a0856aa10855f0c7c1a3d6409a60e9eb7027bd8c127d
+DIST flask-2.3.3.tar.gz 672756 BLAKE2B 70feb2f1ec8bc4742e8da978b7e1063c5f0bcbfda5321f397cba121283376b5b10a275635eac76383945415dbba3b2c4f917e1495851ee1dfd745db97caddec5 SHA512 801b2521c42de7a4cd16005ea6ea7737aaef6c88edacb38ab03e2d78bb4e080e35e540c23e157e2bcdb43e4818b4b7a856c50c6cf41bb17f0b7b2590c0c6aff2
+EBUILD flask-2.3.2.ebuild 1380 BLAKE2B 2f83c841826536472dae52aadc0478cb5644877e4fbee748c09251ccfbdc7711b9a1409ab22031ec3090fda8919367be1c2a917027fbc5038b4d190bbd7d433a SHA512 56aa37b9f7f2230a677440aa96a1cb663d973883155bab219f50a2a9e2a93a580ebec4092122614571a3fe28f48f21681d2b582a0824168b406f8fee449670e2
+EBUILD flask-2.3.3.ebuild 1347 BLAKE2B e5a76be661d413704cbf3094f43d4d065aa7ae4d43c352ee3c2f2e977a08fff759d38074b537eba8c73423a82824428a7380cc9f6445e6491f5924ccbf206d36 SHA512 2b049649a1161afa7902120bb3e1c0bd75a1e6f080eca398c0320ae38bd672d89924b324cc92a289ccd0ac7f84081cf7a789bd70671bb3df4bb2099011b09f10
MISC metadata.xml 386 BLAKE2B b449c54b966bc8943f7b7b12d6126867a89a2759eb749c08f7ad53a174e93ecad07f09b5e30c8562c63ab05df75a82e2f48f550ea8cf3a546f5afc2eef5a896d SHA512 123334db31948046e47f3cdbe0237cdec3dc2207485c8243d1e34e065436995423b6a89909563a6158741a8cc62a7fdad95923870a7114cf69e58ef715e7ec5c
diff --git a/dev-python/flask/flask-2.3.2.ebuild b/dev-python/flask/flask-2.3.2.ebuild
index 7c239b3aff2b..efea6475f841 100644
--- a/dev-python/flask/flask-2.3.2.ebuild
+++ b/dev-python/flask/flask-2.3.2.ebuild
@@ -50,13 +50,6 @@ distutils_enable_sphinx docs \
distutils_enable_tests pytest
python_test() {
- local EPYTEST_DESELECT=()
- if [[ ${EPYTHON} == python3.12 ]]; then
- EPYTEST_DESELECT+=(
- tests/test_basic.py::test_max_cookie_size
- )
- fi
-
epytest -p no:httpbin
}
diff --git a/dev-python/flask/flask-2.3.3.ebuild b/dev-python/flask/flask-2.3.3.ebuild
new file mode 100644
index 000000000000..cb1e62bd91c5
--- /dev/null
+++ b/dev-python/flask/flask-2.3.3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A microframework based on Werkzeug, Jinja2 and good intentions"
+HOMEPAGE="
+ https://palletsprojects.com/p/flask/
+ https://github.com/pallets/flask/
+ https://pypi.org/project/Flask/
+"
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/mitsuhiko/flask.git"
+ inherit git-r3
+else
+ inherit pypi
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="examples"
+
+RDEPEND="
+ >=dev-python/blinker-1.6.2[${PYTHON_USEDEP}]
+ >=dev-python/click-8.1.3[${PYTHON_USEDEP}]
+ >=dev-python/itsdangerous-2.1.2[${PYTHON_USEDEP}]
+ >=dev-python/jinja-3.1.2[${PYTHON_USEDEP}]
+ >=dev-python/werkzeug-2.3.7[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/asgiref-3.2[${PYTHON_USEDEP}]
+ !!dev-python/shiboken2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/pallets-sphinx-themes \
+ dev-python/sphinx-issues \
+ dev-python/sphinx-tabs \
+ dev-python/sphinxcontrib-log-cabinet
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -p no:httpbin
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}