summaryrefslogtreecommitdiff
path: root/dev-python/flask
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
commit43793fab84041cfc5c60c0151d1591b8a69fb24a (patch)
tree6208a7f4fc744684fce0f55acbb47511acace498 /dev-python/flask
parent28e3d252dc8ac8a5635206dfefe1cfe05058d1db (diff)
gentoo resync : 25.08.2018
Diffstat (limited to 'dev-python/flask')
-rw-r--r--dev-python/flask/Manifest4
-rw-r--r--dev-python/flask/flask-1.0.2.ebuild57
-rw-r--r--dev-python/flask/flask-9999.ebuild26
3 files changed, 77 insertions, 10 deletions
diff --git a/dev-python/flask/Manifest b/dev-python/flask/Manifest
index 039b24d80dec..37a1479f14d1 100644
--- a/dev-python/flask/Manifest
+++ b/dev-python/flask/Manifest
@@ -1,4 +1,6 @@
DIST Flask-0.12.2.tar.gz 548510 BLAKE2B bd92d0e7e6ff36d371ffd958708517d16e41d1475af9153bf3d5234c33aa5c0ab415cbd254b711731cf8cffddac94b475f62d9fff2f9fe756b0fa30bb36d4343 SHA512 c00bb807e8fbc943e23a3721acf5b04320e7a58d658bca46bdf83a345b4c4d5729accae338505e134f01bc908adec9555fd94e8c87ef6f0367e6037215c06319
+DIST Flask-1.0.2.tar.gz 644534 BLAKE2B dd024f6f7a68691c759e3fd494a9482c4ab5216b5c7486fc1717346f953678c3198deedd657e7ddd3a5deff57ce31b1afdc40ef2ba9cc2fbed48f3afc223f6d0 SHA512 0ddf5d8bb0b0ae61f990096dffe3cf02744d7986015d05ae2cc09dfe0def17df44e2a4c58e330d17c7bd8c3eb74014dee5e2edef6e300b8e4ed756c251938f52
EBUILD flask-0.12.2.ebuild 1837 BLAKE2B 9a6bca9ba5d490e5ed6d05d63c17d269ec271821ec2293ad587a58038c4d1468ce0c2e520ab75155b260922196a55b1d2a0d972da6270e43f8ca8e2c8fa60e02 SHA512 d3c5d6ab73f049229b352862892392efb03135a3193b00d7891c13025b0c161ed6d8d22014e4fbe5b2e72604006f3cce1640ff10bb42c06198ba49408d910e2f
-EBUILD flask-9999.ebuild 1235 BLAKE2B 6b0b88f074f20770ffc605526307edb3f4175685eb759714ce9065847d4cd44e90773ff03c764170076dc0ee8b13d60a765608b643bfabde11c0f0ded175c88a SHA512 e22e9a737dd51d2e2b936d7dbd3f7116a78db6adad1f43f0ed5714c8932d0a7708d1ed494d5f004d866974962bbd23d6ef0e1a0adb36acc6eb7bbf6f87576b4b
+EBUILD flask-1.0.2.ebuild 1547 BLAKE2B 52d6873119dc9dfd64af46303b01bbd1c69af7028fccb0bb24ada38179c4341f90cb4e9a80389a580191cd803ae68e9139d8460036099ff319fef1c69b1ccefd SHA512 7073f5d7507c8243499d90012310456d0b7e5d727a15f72d1be51e82ee37302397e92a47a83e5204fd5dc8aa8ab6c76daaae6b8932b98bcfb639c39a120fcf78
+EBUILD flask-9999.ebuild 1547 BLAKE2B 52d6873119dc9dfd64af46303b01bbd1c69af7028fccb0bb24ada38179c4341f90cb4e9a80389a580191cd803ae68e9139d8460036099ff319fef1c69b1ccefd SHA512 7073f5d7507c8243499d90012310456d0b7e5d727a15f72d1be51e82ee37302397e92a47a83e5204fd5dc8aa8ab6c76daaae6b8932b98bcfb639c39a120fcf78
MISC metadata.xml 363 BLAKE2B f031e9e0d44bc626f4cc00538e6030e732f97286a09d061cfd8b7e03c8506cc9ddc8caab73d9c10363c5bd0eab1bfe6129a668bd6c66e3d82d9221cfd1175629 SHA512 33989d02b79b82d3256dbbf7402d79580d529e728222d74dbb80f740dfc1f8f1357f03ab5da857ff1821f2bb90f7b7eeae71d89e237516da62656d3d124ef4d6
diff --git a/dev-python/flask/flask-1.0.2.ebuild b/dev-python/flask/flask-1.0.2.ebuild
new file mode 100644
index 000000000000..6b340034d517
--- /dev/null
+++ b/dev-python/flask/flask-1.0.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="A microframework based on Werkzeug, Jinja2 and good intentions"
+HOMEPAGE="https://github.com/pallets/flask/"
+MY_PN="Flask"
+MY_P="${MY_PN}-${PV}"
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/mitsuhiko/flask.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc examples test"
+
+RDEPEND="dev-python/click[${PYTHON_USEDEP}]
+ dev-python/blinker[${PYTHON_USEDEP}]
+ dev-python/itsdangerous[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.10[${PYTHON_USEDEP}]
+ >=dev-python/werkzeug-0.14[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Prevent un-needed d'loading
+ sed -e "s/ 'sphinx.ext.intersphinx',//" -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ PYTHONPATH=${S}/examples/flaskr:${S}/examples/minitwit${PYTHONPATH:+:${PYTHONPATH}} \
+ py.test -v || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ use doc && HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/flask/flask-9999.ebuild b/dev-python/flask/flask-9999.ebuild
index 3329ccaa5a94..6b340034d517 100644
--- a/dev-python/flask/flask-9999.ebuild
+++ b/dev-python/flask/flask-9999.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy{,3} )
inherit distutils-r1
DESCRIPTION="A microframework based on Werkzeug, Jinja2 and good intentions"
-HOMEPAGE="https://pypi.org/project/Flask/"
+HOMEPAGE="https://github.com/pallets/flask/"
MY_PN="Flask"
MY_P="${MY_PN}-${PV}"
if [[ ${PV} == *9999* ]]; then
@@ -16,7 +16,7 @@ if [[ ${PV} == *9999* ]]; then
inherit git-r3
else
SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
S="${WORKDIR}/${MY_P}"
fi
@@ -24,21 +24,29 @@ LICENSE="BSD"
SLOT="0"
IUSE="doc examples test"
-RDEPEND="dev-python/blinker[${PYTHON_USEDEP}]
- >=dev-python/itsdangerous-0.21[${PYTHON_USEDEP}]
- >=dev-python/jinja-2.4[${PYTHON_USEDEP}]
- >=dev-python/werkzeug-0.7[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/click[${PYTHON_USEDEP}]
+ dev-python/blinker[${PYTHON_USEDEP}]
+ dev-python/itsdangerous[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.10[${PYTHON_USEDEP}]
+ >=dev-python/werkzeug-0.14[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+python_prepare_all() {
+ # Prevent un-needed d'loading
+ sed -e "s/ 'sphinx.ext.intersphinx',//" -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
python_compile_all() {
use doc && emake -C docs html
}
python_test() {
- py.test tests || die "Testing failed with ${EPYTHON}"
+ PYTHONPATH=${S}/examples/flaskr:${S}/examples/minitwit${PYTHONPATH:+:${PYTHONPATH}} \
+ py.test -v || die "Testing failed with ${EPYTHON}"
}
python_install_all() {