summaryrefslogtreecommitdiff
path: root/dev-python/flask-themes
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/flask-themes
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/flask-themes')
-rw-r--r--dev-python/flask-themes/Manifest4
-rw-r--r--dev-python/flask-themes/files/fixtests.patch23
-rw-r--r--dev-python/flask-themes/flask-themes-0.1.3-r1.ebuild35
-rw-r--r--dev-python/flask-themes/metadata.xml11
4 files changed, 73 insertions, 0 deletions
diff --git a/dev-python/flask-themes/Manifest b/dev-python/flask-themes/Manifest
new file mode 100644
index 000000000000..0a0675330094
--- /dev/null
+++ b/dev-python/flask-themes/Manifest
@@ -0,0 +1,4 @@
+AUX fixtests.patch 1036 BLAKE2B 5049bf5a41ec630408b2ff4ddd8062529d615271a3d0afbc4a11e264f0ec3a3928deb393cde691351167414619848addac1243359a51afb3ea77be396413da03 SHA512 a3ca31a2bde1539b0ae2a552952f8ef82f7979446eaf7874029d65362bb30151a396becef07f97c12bd5d3264696ee66f2213cd7b3a305bc7ff6faa628320575
+DIST Flask-Themes-0.1.3.tar.gz 9723 BLAKE2B c141363ddcd4d0fa510845fcece4aedf831fed6c1ffac8a6b625265165bce77193ba6240bf5acc9ba990b914d88dabccb76871ac62eff629886348c3b4c7a382 SHA512 baf609b8b08446dda5b5d6d39bc0a2e7406f9270d70924c795243384be8967c82f82adcebe5e060352a0c33b763d600eeb5600d3116c10bdbbb3ceddfadf764a
+EBUILD flask-themes-0.1.3-r1.ebuild 905 BLAKE2B fa53416380c484a47e9614ca2978d80f51c8f77d52e325c8f4b7a025a41e6d234dd46643a436f39bd13285a73d7bd68c1a1d4def6098a4f02a936356feeaaea1 SHA512 1030fcb6d04c62e8c001d28b53bf0b10a0fc35767efdc27b29c586b1b1e9cfbd418635f0fafcac43d69002f0c0734f5832a445b4964628936398528bf674e947
+MISC metadata.xml 315 BLAKE2B 727f5d8c5e8c977bee96f7aade10a33d39107c7f664335f9ac30caa02186df69ecf9548b935e8be235574683fc445be72644dadf84ac2844f26da5014cc88b94 SHA512 87b5e27ef6869c29956604c891a2f8fa0a945817de4642aae7bd735c798cd08c3f1d26196b03ae7db52a83060af468df311e51d95a9a460b2882b4604e05fcd1
diff --git a/dev-python/flask-themes/files/fixtests.patch b/dev-python/flask-themes/files/fixtests.patch
new file mode 100644
index 000000000000..014508e4ddd2
--- /dev/null
+++ b/dev-python/flask-themes/files/fixtests.patch
@@ -0,0 +1,23 @@
+diff -ur Flask-Themes-0.1.3.orig/tests/test-themes.py Flask-Themes-0.1.3/tests/test-themes.py
+--- tests/test-themes.py 2011-07-14 06:36:33.000000000 +0800
++++ tests/test-themes.py 2013-06-10 18:20:25.901480529 +0800
+@@ -129,8 +129,8 @@
+
+ with app.test_request_context('/'):
+ assert template_exists('hello.html')
+- assert template_exists('_themes/cool/hello.html')
+- assert not template_exists('_themes/plain/hello.html')
++ assert template_exists('cool/hello.html')
++ assert not template_exists('themes/plain/hello.html')
+
+ def test_loader(self):
+ app = Flask(__name__)
+@@ -140,7 +140,7 @@
+ with app.test_request_context('/'):
+ if USING_BLUEPRINTS:
+ src = themes_blueprint.jinja_loader.get_source(
+- app.jinja_env, '_themes/cool/hello.html'
++ app.jinja_env, 'cool/hello.html'
+ )
+ else:
+ src = themes_mod.jinja_loader.get_source(
diff --git a/dev-python/flask-themes/flask-themes-0.1.3-r1.ebuild b/dev-python/flask-themes/flask-themes-0.1.3-r1.ebuild
new file mode 100644
index 000000000000..e0ed187173da
--- /dev/null
+++ b/dev-python/flask-themes/flask-themes-0.1.3-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+MY_PN="Flask-Themes"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Infrastructure for theming support in Flask applications"
+HOMEPAGE="https://pythonhosted.org/Flask-Themes/
+ https://pypi.org/project/Flask-Themes/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-python/flask-0.6[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=( "${FILESDIR}"/fixtests.patch )
+
+python_test() {
+ # suite fails miserably under py3. Cannot even find upstream repo to file. pypi.org does NOT help
+ if ! python_is_python3; then
+ PYTHONPATH=.:tests nosetests || die "Tests failed under ${EPYTHON}"
+ fi
+}
diff --git a/dev-python/flask-themes/metadata.xml b/dev-python/flask-themes/metadata.xml
new file mode 100644
index 000000000000..646bcdf7ccef
--- /dev/null
+++ b/dev-python/flask-themes/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">Flask-Themes</remote-id>
+ </upstream>
+</pkgmetadata>