summaryrefslogtreecommitdiff
path: root/dev-python/flask-script/flask-script-2.0.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-python/flask-script/flask-script-2.0.6.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-python/flask-script/flask-script-2.0.6.ebuild')
-rw-r--r--dev-python/flask-script/flask-script-2.0.6.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/flask-script/flask-script-2.0.6.ebuild b/dev-python/flask-script/flask-script-2.0.6.ebuild
index 8510f9ee8f00..29e92f3e53b4 100644
--- a/dev-python/flask-script/flask-script-2.0.6.ebuild
+++ b/dev-python/flask-script/flask-script-2.0.6.ebuild
@@ -2,7 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{5,6} pypy )
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy )
inherit distutils-r1
@@ -19,6 +20,7 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="doc test"
+RESTRICT="!test? ( test )"
RDEPEND=">=dev-python/flask-0.10.1-r1[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
@@ -28,6 +30,8 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MY_P}"
+PATCHES=( "${FILESDIR}/${P}-flask_script-everywhere.patch" )
+
python_compile_all() {
use doc && emake -C docs html
}