summaryrefslogtreecommitdiff
path: root/dev-python/flask-peewee/flask-peewee-0.6.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/flask-peewee/flask-peewee-0.6.5.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/flask-peewee/flask-peewee-0.6.5.ebuild')
-rw-r--r--dev-python/flask-peewee/flask-peewee-0.6.5.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/flask-peewee/flask-peewee-0.6.5.ebuild b/dev-python/flask-peewee/flask-peewee-0.6.5.ebuild
new file mode 100644
index 000000000000..08f05b45ad78
--- /dev/null
+++ b/dev-python/flask-peewee/flask-peewee-0.6.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+RESTRICT="test" # broken
+
+DESCRIPTION="Flask integration layer for the Peewee ORM"
+HOMEPAGE="https://pypi.python.org/pypi/Flask-Admin"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+RDEPEND="dev-python/flask[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/peewee[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+ "
+
+python_test() {
+ nosetests || die "Testing failed with ${EPYTHON}"
+}