summaryrefslogtreecommitdiff
path: root/dev-python/flask-paginate
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
commitf70a1bfc721336d4fc7dfb711c2f518a6b18cf16 (patch)
treee907cb121b30e3c1df1710719c0ddf4029597a47 /dev-python/flask-paginate
parentdb063b515939ab15261136b24e4bc44386335c0c (diff)
gentoo resync : 30.09.2020
Diffstat (limited to 'dev-python/flask-paginate')
-rw-r--r--dev-python/flask-paginate/Manifest4
-rw-r--r--dev-python/flask-paginate/flask-paginate-0.5.3-r1.ebuild33
-rw-r--r--dev-python/flask-paginate/flask-paginate-0.7.0.ebuild24
3 files changed, 26 insertions, 35 deletions
diff --git a/dev-python/flask-paginate/Manifest b/dev-python/flask-paginate/Manifest
index cf3c832f7398..61be89b07590 100644
--- a/dev-python/flask-paginate/Manifest
+++ b/dev-python/flask-paginate/Manifest
@@ -1,3 +1,3 @@
-DIST flask-paginate-0.5.3.tar.gz 118570 BLAKE2B 0c6d1163dcd8144afa80b217ab3a714a39f4015aa732b4c32cf0feee0d7ee06968bd8549651f2941be9c60d3fd36a18e132dd4c174eb4148e63f83e461cbf519 SHA512 fe3cdc808459528c449611b2411c377d46bdef4995cd2851730e90dc0091da15479022f401e31113c4d39f766841d9701f285c81e0ec6293eddd4c8f0821567e
-EBUILD flask-paginate-0.5.3-r1.ebuild 816 BLAKE2B 33c9a4ebd5f8cf7068236c541ef996453859a9bc2586eca36f57d8c8634b938ed951e516a11c3016f6109adff71646d8386d125fc54e546309822afc106275c3 SHA512 218bddaca192b67436a698c9dc7898d45c79b688623c39f1efbc5b9bcdebed101a8e801d087a196e435f9d45d36bf698fbea224f1984a72ea9d8f09f7e824c45
+DIST flask-paginate-0.7.0.tar.gz 119358 BLAKE2B 24c1f3bc77853c9c96bb72d3364e73845f8fd0870606dd96b4261861430bef864a6830dd793f4f6e8a9371c89342dda88c5f976d79ff4a1bec7d687614b2014a SHA512 11c335c08c6a9c32999e5b8ba7a76c1fb04769e5ab679b550efc87497446edbaa1e3ccb62a4c238a0b5585f7ba4067e43f158ae123c3b118db84b90cb5d4f219
+EBUILD flask-paginate-0.7.0.ebuild 593 BLAKE2B 7e551a8ff2f03e99fbbff323cbca30bdce156bd6d666830c4bf38f409764509247669c57a288f983c3bf99e6dcf52a8dc76c88539711601590ea1cd1d126aa9f SHA512 609ecb95be51e187515d3a0122c0f3c37a120b5e83b2bd70f215d12e9c3c3e7c16a88bccab02d1f1cac546e2df883da6b05dc669b2502a651b6e052afd903e0e
MISC metadata.xml 618 BLAKE2B f9feebe27aa247c8458d416154475e0c0234e2ab391d6b9dcf06016c01cebd3d7078efde6079646ff3a8b718911cec1d0699bb5cb4eb2a319b14752718f8fdb5 SHA512 9f6ff105f8b01580628888ecba7a9175e42618ef17e96a90dce15f08335b5dbc76a6b09cbabfd9a7fb659557e04531e4fb46ec3856418d96e18cff5da7a61cba
diff --git a/dev-python/flask-paginate/flask-paginate-0.5.3-r1.ebuild b/dev-python/flask-paginate/flask-paginate-0.5.3-r1.ebuild
deleted file mode 100644
index 22d2f703dbb6..000000000000
--- a/dev-python/flask-paginate/flask-paginate-0.5.3-r1.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{6,7} )
-
-inherit distutils-r1
-
-MY_COMMIT="510ad833106134711868653fb597bf75ea8ac34f"
-
-DESCRIPTION="Pagination support for flask"
-HOMEPAGE="https://flask-paginate.readthedocs.io"
-# https://github.com/lixxu/flask-paginate/issues/68
-SRC_URI="https://github.com/lixxu/flask-paginate/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/flask[${PYTHON_USEDEP}]"
-BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )
-"
-
-S="${WORKDIR}/${PN}-${MY_COMMIT}"
-
-python_test() {
- pytest -vv tests/tests.py || die "tests failed with ${EPYTHON}"
-}
diff --git a/dev-python/flask-paginate/flask-paginate-0.7.0.ebuild b/dev-python/flask-paginate/flask-paginate-0.7.0.ebuild
new file mode 100644
index 000000000000..8435e67f09fc
--- /dev/null
+++ b/dev-python/flask-paginate/flask-paginate-0.7.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=bdepend
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Pagination support for flask"
+HOMEPAGE="https://flask-paginate.readthedocs.io"
+SRC_URI="https://github.com/lixxu/flask-paginate/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/flask[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_test() {
+ pytest -vv tests/tests.py || die "tests failed with ${EPYTHON}"
+}