summaryrefslogtreecommitdiff
path: root/dev-python/flask-paginate
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
commit3517852e3b8a68d1e997770fc0650c5053bafc6c (patch)
tree44068672445b1418489aed82de58df3c470289e7 /dev-python/flask-paginate
parent0f15659d48c193027158492acb726297501202c5 (diff)
gentoo resync : 04.01.2022
Diffstat (limited to 'dev-python/flask-paginate')
-rw-r--r--dev-python/flask-paginate/Manifest2
-rw-r--r--dev-python/flask-paginate/flask-paginate-2021.12.28.ebuild23
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/flask-paginate/Manifest b/dev-python/flask-paginate/Manifest
index acfdc7365468..b9ead84655bd 100644
--- a/dev-python/flask-paginate/Manifest
+++ b/dev-python/flask-paginate/Manifest
@@ -1,3 +1,5 @@
DIST flask-paginate-2021.10.26.tar.gz 120721 BLAKE2B dd37fa131baf20540620c350bca4a17f791df57c82fabd99e644891707259d330d4225fc666d3e5c31410bc17e10531bf735ab8a01e7129641fa81a9d8fbfe82 SHA512 86a782797a9401eecbbfc25c90834ed93d7c376c3eb6bc05f19edf7ad6f174aca01de9dc3b183c0c268e2995d81984fa1568e08aae8964e429c60f01b7b23736
+DIST flask-paginate-2021.12.28.tar.gz 120846 BLAKE2B 63c14a94db4c968ef22a84b28aee2ca3e223fa0a7a32e22644b02b718ae32ea9ece9177b85c66942165e01926b26bb599dd3ae47522ba9bbf9a1c68b7a5ce567 SHA512 3ff805ad2d30aadfd1affabde0b0caccf2c3c2efb54b0997f809e13a76c6db64082d0f003ba4485a824e48d5d2792d99bab5173059ebe5a4077a1aac99b3c4ca
EBUILD flask-paginate-2021.10.26.ebuild 521 BLAKE2B 140807d77a64c79dce577a6f47cbcfffe7f99f8bf90a35064d9937ad366b8bd79b43e964cf57885889db4407726871542f934aa138146b7faca013d136dbbd7c SHA512 8049baacf47d517bb4066793f31a7a6bcb84328677ccaeaa157404fd985a563a164fcad954425c79cf5eb6de274b00014bd77536091c280f87d5ecd240ab6609
+EBUILD flask-paginate-2021.12.28.ebuild 521 BLAKE2B 140807d77a64c79dce577a6f47cbcfffe7f99f8bf90a35064d9937ad366b8bd79b43e964cf57885889db4407726871542f934aa138146b7faca013d136dbbd7c SHA512 8049baacf47d517bb4066793f31a7a6bcb84328677ccaeaa157404fd985a563a164fcad954425c79cf5eb6de274b00014bd77536091c280f87d5ecd240ab6609
MISC metadata.xml 659 BLAKE2B aa9bb930f20057e07df9b82804e8638b99f63e0773c11408617bc1c3c09f0cf8ce1d3383bbf577c42baa0149c271ddc8da113d5a31056e8ad41d4ac8ec4b64eb SHA512 660aba4453bb417b9a54dcf0b190ae16599c00203a19b4c53615b972595e223fb2f6ce8da6f097b34a5408c4cfe09b2a02a2ad19928352acbc8a4ee53b822a41
diff --git a/dev-python/flask-paginate/flask-paginate-2021.12.28.ebuild b/dev-python/flask-paginate/flask-paginate-2021.12.28.ebuild
new file mode 100644
index 000000000000..49d2d8c73c6e
--- /dev/null
+++ b/dev-python/flask-paginate/flask-paginate-2021.12.28.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Pagination support for flask"
+HOMEPAGE="https://flask-paginate.readthedocs.io"
+SRC_URI="https://github.com/lixxu/flask-paginate/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/flask[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest tests/tests.py
+}