summaryrefslogtreecommitdiff
path: root/dev-python/flask-paginate/flask-paginate-2023.10.24.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-23 14:39:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-23 14:39:50 +0100
commitf63d9a9a54cdeeaadc78e460b82f2c9895a69384 (patch)
treec670cb8eb532d97c0d547a9845a6c8c8edbc4070 /dev-python/flask-paginate/flask-paginate-2023.10.24.ebuild
parent386855c4d1ef509c1fd32abd721589c81669613b (diff)
gentoo auto-resync : 23:10:2023 - 14:39:50
Diffstat (limited to 'dev-python/flask-paginate/flask-paginate-2023.10.24.ebuild')
-rw-r--r--dev-python/flask-paginate/flask-paginate-2023.10.24.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/flask-paginate/flask-paginate-2023.10.24.ebuild b/dev-python/flask-paginate/flask-paginate-2023.10.24.ebuild
new file mode 100644
index 000000000000..545297259bb7
--- /dev/null
+++ b/dev-python/flask-paginate/flask-paginate-2023.10.24.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Pagination support for flask"
+HOMEPAGE="
+ https://flask-paginate.readthedocs.io/
+ https://github.com/lixxu/flask-paginate/
+ https://pypi.org/project/flask-paginate/
+"
+SRC_URI="
+ https://github.com/lixxu/flask-paginate/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/flask[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest tests/tests.py
+}