summaryrefslogtreecommitdiff
path: root/dev-python/flask-nav
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /dev-python/flask-nav
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'dev-python/flask-nav')
-rw-r--r--dev-python/flask-nav/Manifest1
-rw-r--r--dev-python/flask-nav/flask-nav-0.6-r2.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/flask-nav/Manifest b/dev-python/flask-nav/Manifest
index 47b1d76c2ea5..5694aa45b6c8 100644
--- a/dev-python/flask-nav/Manifest
+++ b/dev-python/flask-nav/Manifest
@@ -1,3 +1,4 @@
DIST flask-nav-0.6.tar.gz 12270 BLAKE2B eff90b6fc08629139012e2d920b4d464ed06954040a5e97636a7aa4d59d11654839460ef52477cfcec967bd774d942028a53675d682e850f08f6359c5cfbb54e SHA512 a7930687425a53fac9ad9a7cb65c2e2a759a0c9660189965bf37ea6e9925dd869074d37a283801631b3e6c3391f9f4167e0a36294104f72970e876b5a7a0930c
EBUILD flask-nav-0.6-r1.ebuild 1214 BLAKE2B 1e413d5f92f7e91157f35db0a864fc1833aef26cfb0d2195578e1cc7ddb1c29c000fd6bc86005a3c1431edca363989840378c49be72e1a87c749047409016f95 SHA512 d49e661ddc270446eef69cf388257699a656e74a3f04ba5a30411ae0463844af9e642388d5c5e71fc16d843ba9b24805bc5e007a988165dd2548b17c65e97335
+EBUILD flask-nav-0.6-r2.ebuild 739 BLAKE2B ef1c572c0632893a9153e63258bb2396ea430e42add16c7c5744862f88a3bf7ce1271ab696c032d7a87fc8da21e223b9ee6b6876c574c2bc7c967f708b89b9f7 SHA512 b1dc927e630faba728fe3542374ad56b20fbd24b60b70d3862d7c266d7dafa26c487c34f14b0b072a55794310ed11b868892bdd526eb19af90051d25fd864505
MISC metadata.xml 431 BLAKE2B 949791299994b108e48e5bfc9076726ffac5a530783464f54b44deb95646492078e3cb608e99382c04b2ae825336e644433fa5ce7775e7f44d39f6e2840565b5 SHA512 aeae5220fab0583fb7b5f4a0e694791edbaf6b9f5f61fdb04d48b4a91f12726b3101e41097e26980404a19e8b6c5e43723dfc0b61f8d4cfea0f6a5924f8b67f4
diff --git a/dev-python/flask-nav/flask-nav-0.6-r2.ebuild b/dev-python/flask-nav/flask-nav-0.6-r2.ebuild
new file mode 100644
index 000000000000..75935b1a5538
--- /dev/null
+++ b/dev-python/flask-nav/flask-nav-0.6-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Easily create navigation for Flask applications."
+HOMEPAGE="https://pythonhosted.org/flask-nav/"
+# docs are missing from PyPI tarballs
+# https://github.com/mbr/flask-nav/pull/12
+SRC_URI="https://github.com/mbr/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/dominate[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/markupsafe[${PYTHON_USEDEP}]
+ dev-python/visitor[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/alabaster