summaryrefslogtreecommitdiff
path: root/dev-python/flask-nav/flask-nav-0.6-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-11 07:02:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-11 07:02:28 +0100
commit068424b26532f3551a81421a9be67ed206e5c11a (patch)
tree583b8d979899a463a4ef5b26d3d49e85df987623 /dev-python/flask-nav/flask-nav-0.6-r4.ebuild
parentd162ba1860a88062f4cd61f8b52fc303ba0b2991 (diff)
gentoo resync : 11.08.2021
Diffstat (limited to 'dev-python/flask-nav/flask-nav-0.6-r4.ebuild')
-rw-r--r--dev-python/flask-nav/flask-nav-0.6-r4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/flask-nav/flask-nav-0.6-r4.ebuild b/dev-python/flask-nav/flask-nav-0.6-r4.ebuild
new file mode 100644
index 000000000000..c8f197283d11
--- /dev/null
+++ b/dev-python/flask-nav/flask-nav-0.6-r4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{7..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Easily create navigation for Flask applications."
+HOMEPAGE="https://pythonhosted.org/flask-nav/"
+# docs are missing from PyPI tarballs
+# https://github.com/mbr/flask-nav/pull/12
+SRC_URI="https://github.com/mbr/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/dominate[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/markupsafe[${PYTHON_USEDEP}]
+ dev-python/visitor[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/alabaster
+
+PATCHES=(
+ # https://github.com/mbr/flask-nav/pull/27
+ "${FILESDIR}/${P}-py310.patch"
+)