summaryrefslogtreecommitdiff
path: root/dev-python/flask-mongoengine
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/flask-mongoengine
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/flask-mongoengine')
-rw-r--r--dev-python/flask-mongoengine/Manifest4
-rw-r--r--dev-python/flask-mongoengine/flask-mongoengine-0.9.3-r1.ebuild44
-rw-r--r--dev-python/flask-mongoengine/flask-mongoengine-0.9.3.ebuild44
-rw-r--r--dev-python/flask-mongoengine/metadata.xml11
4 files changed, 0 insertions, 103 deletions
diff --git a/dev-python/flask-mongoengine/Manifest b/dev-python/flask-mongoengine/Manifest
deleted file mode 100644
index 3cb193e9d426..000000000000
--- a/dev-python/flask-mongoengine/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-DIST flask-mongoengine-0.9.3.tar.gz 111690 BLAKE2B f94f057bb416715d877154bb2816308324d3f0bb41dfe2002b80ed2f078ab2bffeb62fc7bd53344b7d995111122d0b59a09dfe7700975e151e61fe60f2bdad45 SHA512 15b8031e4f8a9275fa6a602aed8466533fc9e6eb408d8f3316fc8814cc785feeee59dae25f40c1c30371e7e33bcc8727bb866bd99dbee0dc75cf15049576fb3d
-EBUILD flask-mongoengine-0.9.3-r1.ebuild 1167 BLAKE2B 71b8f1ee2834e2365029a105b256251a79c28743038741bc7f0e60a55abd305121642cb30562dc1cbf66dd2494b9fd25ed539eae347692a90cb455936a50b15f SHA512 8c22d5788c0a2453522aca935f50d2489297670f9f6ce318741e184dbdce0b4b424a2a4c8c2d8bc89ecb16de89343e2611dc9727968ed36c9fcc16a4220a1ca0
-EBUILD flask-mongoengine-0.9.3.ebuild 1165 BLAKE2B 2baa05aec028fba50f0f05a9e08413f380ec1e0150977a15d57bbbccc74b169b71dbe32939a38b0c3a9cc7700a05c9eba68c3f6e41e701a0a28abcf16fc88be6 SHA512 0dffec9b6abdda902a1de78710812d23d069ce8e9fb792c27b4a5b017652cd2d678a83f806cdfe47d2eb23a03d4cb68e901bab53b62baa7b95f4139510cb0d98
-MISC metadata.xml 330 BLAKE2B 590f7ce9feffc4646a100469830bd4db174302fe419eb50ebc227fa9e7ae543b4d2a2da0d74b333ee4ea9db3c54a2ec9858f9f3cad7e6e063a4609ba11d18f00 SHA512 02da72329c4df28bb5298edb25f2a79117214feda68a264f7885406e8b8a5287ebad89c31f110ef2a409e1d3ecca525155ff2b6a7b2d2ed798342f02224b8b66
diff --git a/dev-python/flask-mongoengine/flask-mongoengine-0.9.3-r1.ebuild b/dev-python/flask-mongoengine/flask-mongoengine-0.9.3-r1.ebuild
deleted file mode 100644
index 372ecdb01778..000000000000
--- a/dev-python/flask-mongoengine/flask-mongoengine-0.9.3-r1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit distutils-r1
-
-RESTRICT="test" # requires running MongoDB server
-
-DESCRIPTION="Flask support for MongoDB and with WTF model forms"
-HOMEPAGE="https://pypi.org/project/flask-mongoengine/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc test"
-
-RDEPEND=">=dev-python/flask-0.8[${PYTHON_USEDEP}]
- >=dev-python/mongoengine-0.7.10[${PYTHON_USEDEP}]
- dev-python/flask-wtf[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- # fix distutils sandbox violation due to missing test-deps in normal build
- sed -i '/test_requirements/d' setup.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- nosetests || die "Testing failed with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/flask-mongoengine/flask-mongoengine-0.9.3.ebuild b/dev-python/flask-mongoengine/flask-mongoengine-0.9.3.ebuild
deleted file mode 100644
index 28d61b954994..000000000000
--- a/dev-python/flask-mongoengine/flask-mongoengine-0.9.3.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5} )
-
-inherit distutils-r1
-
-RESTRICT="test" # requires running MongoDB server
-
-DESCRIPTION="Flask support for MongoDB and with WTF model forms"
-HOMEPAGE="https://pypi.org/project/flask-mongoengine/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc test"
-
-RDEPEND=">=dev-python/flask-0.8[${PYTHON_USEDEP}]
- >=dev-python/mongoengine-0.7.10[${PYTHON_USEDEP}]
- dev-python/flask-wtf[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- # fix distutils sandbox violation due to missing test-deps in normal build
- sed -i '/test_requirements/d' setup.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- nosetests || die "Testing failed with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/flask-mongoengine/metadata.xml b/dev-python/flask-mongoengine/metadata.xml
deleted file mode 100644
index 2ef0c031b99c..000000000000
--- a/dev-python/flask-mongoengine/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <upstream>
- <remote-id type="pypi">flask-mongoengine</remote-id>
- </upstream>
-</pkgmetadata>