summaryrefslogtreecommitdiff
path: root/dev-python/flask-login/flask-login-0.6.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-26 20:59:46 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-26 20:59:46 +0100
commit1d4cc2fdaa7a04ed1fe39b6cf1d892bd83bd8030 (patch)
tree15bcf4c47e609ca1bd3dc164c91a9cfbe566dd3f /dev-python/flask-login/flask-login-0.6.2.ebuild
parent1503b28e7a30c164cab750c27268f704b8a5cec6 (diff)
gentoo auto-resync : 26:07:2022 - 20:59:46
Diffstat (limited to 'dev-python/flask-login/flask-login-0.6.2.ebuild')
-rw-r--r--dev-python/flask-login/flask-login-0.6.2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/flask-login/flask-login-0.6.2.ebuild b/dev-python/flask-login/flask-login-0.6.2.ebuild
new file mode 100644
index 000000000000..132e7072e390
--- /dev/null
+++ b/dev-python/flask-login/flask-login-0.6.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Login session support for Flask"
+HOMEPAGE="
+ https://github.com/maxcountryman/flask-login/
+ https://pypi.org/project/Flask-Login/
+"
+SRC_URI="
+ https://github.com/maxcountryman/flask-login/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/flask-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/werkzeug-1.0.1[${PYTHON_USEDEP}]
+"
+DEPEND="
+ test? (
+ dev-python/asgiref[${PYTHON_USEDEP}]
+ dev-python/blinker[${PYTHON_USEDEP}]
+ dev-python/semantic_version[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -p no:httpbin
+}