summaryrefslogtreecommitdiff
path: root/dev-python/flask-htmlmin/flask-htmlmin-2.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
commit46eedbedafdb0040c37884982d4c775ce277fb7b (patch)
treedb33a91259730be84999e13a8d8168c799f50ac0 /dev-python/flask-htmlmin/flask-htmlmin-2.2.0.ebuild
parente23a08d0c97a0cc415aaa165da840b056f93c997 (diff)
gentoo resync : 20.10.2021
Diffstat (limited to 'dev-python/flask-htmlmin/flask-htmlmin-2.2.0.ebuild')
-rw-r--r--dev-python/flask-htmlmin/flask-htmlmin-2.2.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/flask-htmlmin/flask-htmlmin-2.2.0.ebuild b/dev-python/flask-htmlmin/flask-htmlmin-2.2.0.ebuild
new file mode 100644
index 000000000000..5cdcf795a321
--- /dev/null
+++ b/dev-python/flask-htmlmin/flask-htmlmin-2.2.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_P="Flask-HTMLmin-${PV}"
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Minimize your flask rendered html"
+HOMEPAGE="https://github.com/hamidfzm/Flask-HTMLmin"
+SRC_URI="
+ https://github.com/hamidfzm/Flask-HTMLmin/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-text/cssmin[${PYTHON_USEDEP}]
+ app-text/htmlmin[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e '/pytest-runner/d' -i setup.py || die
+ distutils-r1_src_prepare
+}