summaryrefslogtreecommitdiff
path: root/dev-python/flask-debug
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-23 07:00:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-23 07:00:28 +0100
commite23cdda4dbb0c83b9e682ab5e916085a35203da5 (patch)
tree5a4ac448a3b288b731c24d947e0ce52df3cab07b /dev-python/flask-debug
parent8187a741807f3e9a9e26304973cf18087dcf2560 (diff)
gentoo resync : 23.06.2018
Diffstat (limited to 'dev-python/flask-debug')
-rw-r--r--dev-python/flask-debug/Manifest4
-rw-r--r--dev-python/flask-debug/flask-debug-0.4.3.ebuild24
-rw-r--r--dev-python/flask-debug/metadata.xml6
3 files changed, 14 insertions, 20 deletions
diff --git a/dev-python/flask-debug/Manifest b/dev-python/flask-debug/Manifest
index 29fbd8aaaf7d..094e26d62cf4 100644
--- a/dev-python/flask-debug/Manifest
+++ b/dev-python/flask-debug/Manifest
@@ -1,3 +1,3 @@
DIST flask-debug-0.4.3.tar.gz 9148 BLAKE2B 9263a4df08f1a9518a42a025a14a89b902c62ab08b25d79b3dfffb25675a47785d0bf9075290190ee4622a30a89e190a465a87986b47ceed7d724ce0b59ad218 SHA512 7bc1cf9f88f28e2ca5a24c1454dcdb4e2a450eff3c00329f299c3840032e0803079f565652974f4c3a0e5aac443365ce47a3d2c2fee8e21e2e0c7150367e8816
-EBUILD flask-debug-0.4.3.ebuild 1206 BLAKE2B 13e19f643fa2d8cd636bc29bf2eb1f0e66b4c40059a3c75b217915f3543efa9ab11a4d4d049160fbfb8e88fb02bcdc6f2122d2918a07809399ca17833b73bd8f SHA512 6f13e6c8f148a05341883bc7ff91e8667e0c099aa4c53c2b9363410dfa6096e5971b3b0e08ed8fdf51f3ae36f30c5d663d3b70c58a4b02d999857877ce2c7eba
-MISC metadata.xml 561 BLAKE2B 816db76d01f8362e977630a04db810c2c87ca1b4e5435dac4866fb40c0d9a7544452933fe9861f6e9e48dc2ce8c3d60cc5314e68534017b2be7c20c1af50a1d2 SHA512 f35b563a78757a00cf59b714b073e689367c4f9f29cfa2ad7c3613decd6e2badc521a61263882dda3e0bcc3c9cd16be3066cbc9a37b27f2982233f6d03ae700d
+EBUILD flask-debug-0.4.3.ebuild 1195 BLAKE2B bd2b740de12688eeeb31784a122547f62aebde2530dfc0043334b1c44fbf93864b6a32b740f06a83aef254956ef50dfcbdacbdf84f652ce307080463e4ebadf3 SHA512 272e1a8931a0c8e7d9762cc3608105037c9c696d81d4848386ed99184a66ad8116ecbab63954dad4221e6c198d5aaf0b2f1dabd5e4baefabdb07a0e7de07b63d
+MISC metadata.xml 437 BLAKE2B a47818cc11d0365a7a03da5ea3c9fa7bb60d3ec783d63bd8780e11db56dd2093e39ecf4633f462f17cf95e97c93dfbc64301c1c321450a985dcfe28bd6a1bbb5 SHA512 93d72b4859ed2838632f65de971957dc279ccb5897b703b61baf5287a5748f33a7b94f484f8f457b6e4a4e7c5c25e7a5f35506c86e3f539ad7240bbc66748398
diff --git a/dev-python/flask-debug/flask-debug-0.4.3.ebuild b/dev-python/flask-debug/flask-debug-0.4.3.ebuild
index d5e0d4fcc1e2..cccb072ac7a3 100644
--- a/dev-python/flask-debug/flask-debug-0.4.3.ebuild
+++ b/dev-python/flask-debug/flask-debug-0.4.3.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+EAPI=7
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6}} )
inherit distutils-r1
MY_PN="Flask-Debug"
-DESCRIPTION="Configures Flask applications in a canonical way"
+DESCRIPTION="Flask extension that displays various debugging insights during development"
HOMEPAGE="https://github.com/mbr/Flask-Debug"
# PyPI tarballs don't include tests
# https://github.com/mbr/Flask-Debug/pull/2
@@ -21,15 +21,15 @@ IUSE="doc test"
RDEPEND="
dev-python/flask[${PYTHON_USEDEP}]
dev-python/inflection[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? (
- dev-python/pytest-runner[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
)
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
"
S="${WORKDIR}/${MY_PN}-${PV}"
@@ -40,14 +40,12 @@ python_prepare_all() {
}
python_compile_all() {
- use doc && emake -C docs html
+ if use doc; then
+ sphinx-build docs docs/_build/html || die
+ HTML_DOCS=( docs/_build/html/. )
+ fi
}
python_test() {
py.test || die "Tests failed with ${EPYTHON}"
}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/flask-debug/metadata.xml b/dev-python/flask-debug/metadata.xml
index 5838f9e89967..b409b5ff6b39 100644
--- a/dev-python/flask-debug/metadata.xml
+++ b/dev-python/flask-debug/metadata.xml
@@ -2,13 +2,9 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
- <email>sautier.louis@gmail.com</email>
+ <email>sbraz@gentoo.org</email>
<name>Louis Sautier</name>
</maintainer>
- <maintainer type="project">
- <email>proxy-maint@gentoo.org</email>
- <name>Proxy Maintainers</name>
- </maintainer>
<upstream>
<remote-id type="pypi">Flask-Debug</remote-id>
<remote-id type="github">mbr/Flask-Debug</remote-id>