summaryrefslogtreecommitdiff
path: root/dev-python/flask-cors/flask-cors-3.0.10-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-28 10:36:33 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-28 10:36:33 +0100
commita150275298c698f2489d072115ed2e2591204b31 (patch)
treeae013137d5a37f6c36eb6686defdf7ab36d25baa /dev-python/flask-cors/flask-cors-3.0.10-r1.ebuild
parent2130804eda00268ce2a34eb936167bcfeb4281a0 (diff)
gentoo auto-resync : 28:07:2023 - 10:36:33
Diffstat (limited to 'dev-python/flask-cors/flask-cors-3.0.10-r1.ebuild')
-rw-r--r--dev-python/flask-cors/flask-cors-3.0.10-r1.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-python/flask-cors/flask-cors-3.0.10-r1.ebuild b/dev-python/flask-cors/flask-cors-3.0.10-r1.ebuild
deleted file mode 100644
index 4ca561da6c76..000000000000
--- a/dev-python/flask-cors/flask-cors-3.0.10-r1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-if [[ "${PV}" == "9999" ]]; then
- EGIT_REPO_URI="https://github.com/corydolphin/flask-cors.git"
- inherit git-r3
-else
- SRC_URI="
- https://github.com/corydolphin/flask-cors/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
- "
- KEYWORDS="amd64 ~arm ~arm64 ~ppc64 ~riscv x86"
-fi
-
-DESCRIPTION="A Flask extension for Cross Origin Resource Sharing (CORS)"
-HOMEPAGE="
- https://github.com/corydolphin/flask-cors/
- https://pypi.org/project/Flask-Cors/
-"
-
-LICENSE="MIT"
-SLOT="0"
-
-RDEPEND="
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/packaging[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs \
- dev-python/sphinx-rtd-theme \
- dev-python/sphinxcontrib-httpdomain