summaryrefslogtreecommitdiff
path: root/dev-python/flask-compress
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /dev-python/flask-compress
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'dev-python/flask-compress')
-rw-r--r--dev-python/flask-compress/Manifest3
-rw-r--r--dev-python/flask-compress/flask-compress-1.5.0.ebuild36
-rw-r--r--dev-python/flask-compress/metadata.xml15
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/flask-compress/Manifest b/dev-python/flask-compress/Manifest
new file mode 100644
index 000000000000..357d20f0d021
--- /dev/null
+++ b/dev-python/flask-compress/Manifest
@@ -0,0 +1,3 @@
+DIST Flask-Compress-1.5.0.tar.gz 6473 BLAKE2B eba68544018d587a7651c07739ac14218ff9918031fee740893245816daa7494d4998cf60b533971ba8dc0c7c9e3d1e1c14ee746d9e29deab70b30478a3c4eae SHA512 fe2d1dfef8be8d04b78a2938dd52a1f6068e6c35741f593fbb0d3d050b789b8d70188d683f7028b92a180653afda0566bda29b82475b20444f6563c8620ff1ec
+EBUILD flask-compress-1.5.0.ebuild 701 BLAKE2B 4a1a692533d8c086cdcbb68146b8d2256a56541f55c8e2647964a64c0f6a5faa7274b25411edd26967727a339ba068ef9f1c3374beac0872775e685de08660ef SHA512 fc7a5fc06b85ced250f60bcf213c9c2f1d92d437fc6ddd8112bfbf2580c3de44891bef71ae165a8d474c5919138aa375356e9d702aa9fec36c86e2231695b119
+MISC metadata.xml 431 BLAKE2B f3d71b4c8b86528458a7dbbefd527c9b32252338950f799ec315351454219dafed0b84e74e1e2443b48114a50c8bade0953648cd5ec441b2722fee4e63e5beb6 SHA512 d6cc23df1b882978c77421c21b2a00ea7bdc6781ebd283b00cefdff1efd79e6822025e63f2fc64d2268237f114a6e0f6b451487060d66bfa30295312518f6bbb
diff --git a/dev-python/flask-compress/flask-compress-1.5.0.ebuild b/dev-python/flask-compress/flask-compress-1.5.0.ebuild
new file mode 100644
index 000000000000..115c157c65c1
--- /dev/null
+++ b/dev-python/flask-compress/flask-compress-1.5.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+MY_PN="Flask-Compress"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Compress responses in your Flask app with gzip"
+HOMEPAGE="https://pypi.org/project/Flask-Compress"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ app-arch/brotli[python,${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ pytest
+}
diff --git a/dev-python/flask-compress/metadata.xml b/dev-python/flask-compress/metadata.xml
new file mode 100644
index 000000000000..09014f03117e
--- /dev/null
+++ b/dev-python/flask-compress/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>titanofold@gentoo.org</email>
+ <name>Aaron W. Swenson</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">Flask-Gravatar</remote-id>
+ </upstream>
+</pkgmetadata>