summaryrefslogtreecommitdiff
path: root/dev-python/flaky
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/flaky
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/flaky')
-rw-r--r--dev-python/flaky/Manifest3
-rw-r--r--dev-python/flaky/flaky-3.7.0-r1.ebuild4
-rw-r--r--dev-python/flaky/flaky-3.7.0-r2.ebuild42
3 files changed, 46 insertions, 3 deletions
diff --git a/dev-python/flaky/Manifest b/dev-python/flaky/Manifest
index fe9daf0f49ac..64f51d58f100 100644
--- a/dev-python/flaky/Manifest
+++ b/dev-python/flaky/Manifest
@@ -1,3 +1,4 @@
DIST flaky-3.7.0.tar.gz 29591 BLAKE2B 747fbda71055bba937abf3e7b97691c1f4b222f085069d1815d5a9eba669464d2ed5d6dcf1842ae82f1970de5cd5e3aea5b12476bfa2d9282549ad0cc62901e9 SHA512 b399f6e1323d6ca341803ac6f1eb318bf24dc37182d0b49b89bb81b9466dd36271ad6dbb9f48ea6fa4760ee631f1482bb6f49c64f4d4520c40634089c1b64f9a
-EBUILD flaky-3.7.0-r1.ebuild 1284 BLAKE2B 9e7e41cc890dff994a561c3f7453c2e099e1e6780b4aeb443901b86aa8ede30dbad4ad2b0662abdbcb591ac5c9dc29ae440f57705a10a618311b1bab11706abf SHA512 66e1094d9846adfa4e4cd4f0319b181f536fdca4bc432f37f7ec14980273d435f0953f233bcc27a1e6cb2ac9f153f75f55b79a3db584abdbd87b48092718db9e
+EBUILD flaky-3.7.0-r1.ebuild 1291 BLAKE2B ce938c1587e4cbec678d2fd529d47d8ab768040f28e4fc9a2cc4ebefca52f2e4f2c8ae95c06f6fcbc9f45840a6181b7ae861ae8d860e0c801063eb14cd12b8b4 SHA512 38b154e82887bc7884d9adf77599bbff17b9e43c2d5bb5c0dcdb63f930b30979aa469199949c2a496a3de0ad13e8d86da54c5bf388e992258c1b8c105d3974ef
+EBUILD flaky-3.7.0-r2.ebuild 1487 BLAKE2B 29fae1f4fea3e2654ebe8b2166be4dc573c738870671588449f3649cd83b82461c6af7067dd0a0d0a394a995f6cbf03f2f5594a4995d3c07bcfaf3da240fafc1 SHA512 f6efb5c6b6191b2f543053ff955750094d3db32db5e32eaba65db0a6e5e033564121fcd5f6afcc5b2814d76ed8d89f3d91bc468743788752bd1b56a951c1430c
MISC metadata.xml 395 BLAKE2B 06158c93157879bd7b181e833d84ea33a315103214cfaa54a092f965900f05f705183b74738543ac6bb83beb62de562a59ef43b734a74c9f3d0d5d677e8e00d1 SHA512 2d237ebccf03db7fc42fac5370f1046834646bdfc5755e2298e9cac131363e47e496d9d0f0d00ad914764bcbc2deaee8b7182ae3c32e18f95766351da50028aa
diff --git a/dev-python/flaky/flaky-3.7.0-r1.ebuild b/dev-python/flaky/flaky-3.7.0-r1.ebuild
index 0253d0440db4..b55ec43961a7 100644
--- a/dev-python/flaky/flaky-3.7.0-r1.ebuild
+++ b/dev-python/flaky/flaky-3.7.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -14,7 +14,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
SLOT="0"
LICENSE="Apache-2.0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="test"
RESTRICT="!test? ( test )"
diff --git a/dev-python/flaky/flaky-3.7.0-r2.ebuild b/dev-python/flaky/flaky-3.7.0-r2.ebuild
new file mode 100644
index 000000000000..b5f07b9b77d0
--- /dev/null
+++ b/dev-python/flaky/flaky-3.7.0-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Plugin for nose or py.test that automatically reruns flaky tests"
+HOMEPAGE="https://pypi.org/project/flaky/ https://github.com/box/flaky"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? (
+ dev-python/genty[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/nose[${PYTHON_USEDEP}]
+ ' python3_{8..10} pypy3)
+ )
+"
+
+python_test() {
+ epytest -k 'example and not options' --doctest-modules test/test_pytest/ || die
+ epytest -p no:flaky test/test_pytest/test_flaky_pytest_plugin.py || die
+ epytest --force-flaky --max-runs 2 test/test_pytest/test_pytest_options_example.py || die
+
+ # please keep this in sync with python_gen_cond_dep!
+ if has "${EPYTHON}" python3_{8..10} pypy3; then
+ "${EPYTHON}" -m nose --with-flaky --exclude="test_nose_options_example" test/test_nose/ || die
+ "${EPYTHON}" -m nose --with-flaky --force-flaky --max-runs 2 test/test_nose/test_nose_options_example.py || die
+ fi
+}