summaryrefslogtreecommitdiff
path: root/dev-python/flaky
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/flaky
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/flaky')
-rw-r--r--dev-python/flaky/Manifest5
-rw-r--r--dev-python/flaky/flaky-3.1.1.ebuild45
-rw-r--r--dev-python/flaky/flaky-3.4.0.ebuild45
-rw-r--r--dev-python/flaky/metadata.xml12
4 files changed, 0 insertions, 107 deletions
diff --git a/dev-python/flaky/Manifest b/dev-python/flaky/Manifest
deleted file mode 100644
index 8559916ed011..000000000000
--- a/dev-python/flaky/Manifest
+++ /dev/null
@@ -1,5 +0,0 @@
-DIST flaky-3.1.1.tar.gz 29136 BLAKE2B fe2f47356e0279885cc294f22bc4588b502c7ada1d3f7a3728b1e3127f011f5900187669bb4e0755e706a1bd77e1804c42986a07c6d3dc58fe085967adb6957c SHA512 039ad115a52b8b3a31bba045874e1860f1e04ea9cf878316226fb22af3c715b3893570c2f7380cf8467107f1a83a4ff69d0e9135daeb2dbea4b8f873a192815c
-DIST flaky-3.4.0.tar.gz 29197 BLAKE2B 8f551a414cb06f5259d37785eb769a77105b1039398462288eeaeeb6acea8456c30cc7da6cf515cd99be2adb19a77282d2d0d3abe795761985f45ffd062de508 SHA512 14fda6312e4eb8260a8190204622a7dd274d0c946dda07ec8aa65e8c341f7f4a701c704c807f50eacf77589231b37c3bb06eec18d60a718f24e9b0182f7e8cb5
-EBUILD flaky-3.1.1.ebuild 1389 BLAKE2B cc36048c3dfe308c8166cf42c2ac3bea5289fe758433e8ef86c3ffc891298aa9db8a5332df415884e3b6f82a0943ada48d90bd9a7c921d8ab8bdd4ae1d4e666c SHA512 b5fdc991adf8d32e765dd5866aac03f69ab5f999af0c3d755de3915425fd4e6690077280f6bf58739ed2702db17f45ce0700887caddf5066a4220040dcbd4d99
-EBUILD flaky-3.4.0.ebuild 1410 BLAKE2B d4c21789e8bca78aee0bfed6843c2a47ee8d85174879bea0e0a41752beb504a3234833e05411da1e12237fc4d977fd3cc789a65784e01bf3aaa2fd93db4c711f SHA512 e2f915e322609583d9110971bdeb3ba7a25f340ed54974867fd3f25e1c11dd2b52f0bb2c14ee6b1054195f4bac8060cfbb507e281e2313200cf6b348615709ed
-MISC metadata.xml 369 BLAKE2B ffa607acfbc98fc2e539492f87b55cedb039b39b3cdb7ce07cf9dcebe1a1559296284b27d06fc6262f362c0ea8577e23f4bef07ffd01a94c4d981fa060384d5a SHA512 da1597d14b2e3f9bc56e48064718a2a52bc1615d982d679d8c971f1fb1b9c25169d5412f99542f808fa42f958e1bb589e7615a13077a7d1b0574acbec1d4b1dd
diff --git a/dev-python/flaky/flaky-3.1.1.ebuild b/dev-python/flaky/flaky-3.1.1.ebuild
deleted file mode 100644
index 345ac0686287..000000000000
--- a/dev-python/flaky/flaky-3.1.1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
-
-inherit distutils-r1
-
-DESCRIPTION="Plugin for nose or py.test that automatically reruns flaky tests"
-HOMEPAGE="https://pypi.org/project/flaky/ https://github.com/box/flaky"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="Apache-2.0"
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/genty[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )
-"
-python_prepare_all() {
- cat >> test/__init__.py <<- EOF
- # coding: utf-8
-
- from __future__ import unicode_literals
- EOF
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- nosetests --with-flaky --exclude="test_nose_options_example" test/test_nose/ || die
- py.test -k 'example and not options' --doctest-modules test/test_pytest/ || die
- py.test -p no:flaky test/test_pytest/test_flaky_pytest_plugin.py || die
- nosetests --with-flaky --force-flaky --max-runs 2 test/test_nose/test_nose_options_example.py || die
- py.test --force-flaky --max-runs 2 test/test_pytest/test_pytest_options_example.py || die
-}
diff --git a/dev-python/flaky/flaky-3.4.0.ebuild b/dev-python/flaky/flaky-3.4.0.ebuild
deleted file mode 100644
index 60c307a51b05..000000000000
--- a/dev-python/flaky/flaky-3.4.0.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
-
-inherit distutils-r1
-
-DESCRIPTION="Plugin for nose or py.test that automatically reruns flaky tests"
-HOMEPAGE="https://pypi.org/project/flaky/ https://github.com/box/flaky"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="Apache-2.0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/genty[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )
-"
-python_prepare_all() {
- cat >> test/__init__.py <<- EOF
- # coding: utf-8
-
- from __future__ import unicode_literals
- EOF
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- nosetests --with-flaky --exclude="test_nose_options_example" test/test_nose/ || die
- py.test -k 'example and not options' --doctest-modules test/test_pytest/ || die
- py.test -p no:flaky test/test_pytest/test_flaky_pytest_plugin.py || die
- nosetests --with-flaky --force-flaky --max-runs 2 test/test_nose/test_nose_options_example.py || die
- py.test --force-flaky --max-runs 2 test/test_pytest/test_pytest_options_example.py || die
-}
diff --git a/dev-python/flaky/metadata.xml b/dev-python/flaky/metadata.xml
deleted file mode 100644
index 8487b6711c9e..000000000000
--- a/dev-python/flaky/metadata.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <upstream>
- <remote-id type="github">box/flaky</remote-id>
- <remote-id type="pypi">flaky</remote-id>
- </upstream>
-</pkgmetadata>