summaryrefslogtreecommitdiff
path: root/dev-python/flake8
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-21 02:09:25 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-21 02:09:25 +0000
commitafcb9236a72cf602364c28b9bde6648e4a7f1ca5 (patch)
tree9608aa2c881b2688207832334c938f0e38d5c71c /dev-python/flake8
parentd3419aa304ff2564036398be5e8ed4bdeaeaa007 (diff)
gentoo auto-resync : 21:01:2024 - 02:09:25
Diffstat (limited to 'dev-python/flake8')
-rw-r--r--dev-python/flake8/Manifest2
-rw-r--r--dev-python/flake8/flake8-6.1.0.ebuild63
2 files changed, 0 insertions, 65 deletions
diff --git a/dev-python/flake8/Manifest b/dev-python/flake8/Manifest
index b28df7af9e72..29b83aaf7780 100644
--- a/dev-python/flake8/Manifest
+++ b/dev-python/flake8/Manifest
@@ -1,5 +1,3 @@
-DIST flake8-6.1.0.gh.tar.gz 139267 BLAKE2B 69210f4ebe5dd4b56425fca9289349820cc5dcee515f75cb855b095dc1a0a6ba380448f14fca19423940d853383576ddc665c5a7bd27f8aa96940ac410d8742b SHA512 a44d245b023acbb89e64071f6cb76f5543e538472a8815fa329a3b3671133cc6f96f246d83877a2a9ac91c32ecdf65858f8edf996efba77906af74b1632b74c8
DIST flake8-7.0.0.gh.tar.gz 138456 BLAKE2B faf0b54ede3c3184e12986fb9247f73a149a5fd9ebba90578aae8550d2749bcacdab1fa4699ea0b8d69309d0bd5c26dd5162c54a8f8eb33ed64009c919e147fe SHA512 cebcd61d266c6d2f837178d0708217b471662e81dabaa911850883657307747180173c5f6cde11abc2b14381baecff9d6adeca2979bcb85be03a4a6ff57de2c4
-EBUILD flake8-6.1.0.ebuild 1623 BLAKE2B 15b8af981c1f96e17edff272ae97aeb382c9359088c82142f3edbac78a6fb9466e86e90b1b2b32bd55400a5bca3c70e73649878f09fff511c551f63a661b9171 SHA512 3e7713502ca13cf0b28ac9ec49d07baca4daffbdced406fa896f5d5960d346348b0393097b5cc7017a6cc7765243cb2a1a7100c87bbfb68625a316c5eed523a5
EBUILD flake8-7.0.0.ebuild 1623 BLAKE2B 7dca94d88d00a024bf7947625dc24f63fc02ca91bb22591e4fbb2c36f85a74f8f88ed2e0d54d88b032ae2095592ba17e194e0546ed74365bb1ec7ddda446868d SHA512 9c504c5e8260ab0ab548810a4f50916ae14546cffe1caecc9b76f3f00566a2e8b1e14590f7c88a8eb024b40fca0e365d520f76b259c81c89c6c19007dd33dda1
MISC metadata.xml 399 BLAKE2B 01ae165c898af67195582e1aaf867b9f9fc937e56b87f09a812d21c9d1175131c25561524ba76857c1630a117a21bc43eeef907c2a34ab9e9b38866dc2f9430e SHA512 8f149a017f4fef8f8fe0fef037e589694e0c3b3689990f97f38ed23fb9b5c5170985fc1fd7814ef70b8200db66cb9367dcfc9bf6453f8742092335a1c3c8fae6
diff --git a/dev-python/flake8/flake8-6.1.0.ebuild b/dev-python/flake8/flake8-6.1.0.ebuild
deleted file mode 100644
index 1d92666ad0fb..000000000000
--- a/dev-python/flake8/flake8-6.1.0.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="A wrapper around PyFlakes, pep8 & mccabe"
-HOMEPAGE="
- https://github.com/PyCQA/flake8/
- https://pypi.org/project/flake8/
-"
-SRC_URI="
- https://github.com/PyCQA/flake8/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-
-RDEPEND="
- <dev-python/pyflakes-3.2.0[${PYTHON_USEDEP}]
- >=dev-python/pyflakes-3.1.0[${PYTHON_USEDEP}]
- <dev-python/pycodestyle-2.12.0[${PYTHON_USEDEP}]
- >=dev-python/pycodestyle-2.11.0[${PYTHON_USEDEP}]
-"
-PDEPEND="
- >=dev-python/mccabe-0.7.0[${PYTHON_USEDEP}]
- <dev-python/mccabe-0.8.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- ${RDEPEND}
- test? (
- ${PDEPEND}
- )
-"
-
-distutils_enable_sphinx docs/source \
- dev-python/sphinx-prompt \
- dev-python/sphinx-rtd-theme
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # fails if additional flake8 plugins are installed
- tests/integration/test_plugins.py::test_local_plugin_can_add_option
- )
- if [[ ${EPYTHON} == pypy3 ]]; then
- EPYTEST_DESELECT+=(
- # problem with pypy3.10 in dev-python/pyflakes
- # https://github.com/PyCQA/pyflakes/issues/779
- tests/integration/test_main.py::test_malformed_per_file_ignores_error
- tests/integration/test_main.py::test_tokenization_error_but_not_syntax_error
- tests/integration/test_main.py::test_tokenization_error_is_a_syntax_error
- )
- fi
-
- epytest
-}