summaryrefslogtreecommitdiff
path: root/dev-python/flake8
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
commit5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (patch)
tree66e860a5099bcad013f1cf667255dc372a7c11b3 /dev-python/flake8
parent7218e1b46bceac05841e90472501742d905fb3fc (diff)
gentoo resync : 20.03.2021
Diffstat (limited to 'dev-python/flake8')
-rw-r--r--dev-python/flake8/Manifest2
-rw-r--r--dev-python/flake8/flake8-3.9.0.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/flake8/Manifest b/dev-python/flake8/Manifest
index fb458914ac0f..c7acbf2c69a8 100644
--- a/dev-python/flake8/Manifest
+++ b/dev-python/flake8/Manifest
@@ -1,3 +1,5 @@
DIST flake8-3.8.4.tar.gz 163583 BLAKE2B 221234931365912adffec99c7c6761d2f35918222bee902ade4d8009d24f6918c66d23fc4b973fe653152cc6857b62ba859780b0d9de53fb91b7ea0379bee9d0 SHA512 51ed09beed50175573e6184b404431b3f89aa6594c40c70ed8288982fe12c2a68992e36d69c99013188f03555bf9fef1ba4f111f8e389cef1e1daa69b41ff5b0
+DIST flake8-3.9.0.tar.gz 164144 BLAKE2B e265a392445038b04ee2d8c24a763b4b1eebe9682295b70d14c07dbd739b34abbe5f76bc01dd31df7c666a106b62c5312c0522d6771c5649a91d2720a9d14467 SHA512 bfeaa13737f23318da8673c28f0f10463c0aad71a01fe70797321de3b9b7efbe7b5d0ee0664b8440db6b35d7f29f157848757d55fcac531a0c6da6371d681b65
EBUILD flake8-3.8.4.ebuild 1188 BLAKE2B 7b0c81113db70735cdb5757df5142aaf6a387133cf2a28c6c89cac1d316a3e632a0f3f39408d14e72a096a57040cb104940dda83b6c0c0c315e4cf7c7046f947 SHA512 a3b9b959da19ca3406c355108d3df65d7d17c7a33bf597e86d34b6fa51891fdff8cfb4831cdda6b36f78af19bc2045025205957bdf98c9484ed3d73968c01659
+EBUILD flake8-3.9.0.ebuild 1195 BLAKE2B 07d56ee894e891b073cb5d6e547f89d35771bad3b775abef2a2b27d91e4c56e2333ae45b1d59ed59a6b1d582c25177157e694bb4fe3c577cb57abb33a1e5944f SHA512 4e92a41c0d0de016ffd51b11d2174320e24ac67e5afd6f1f13abc67858db57c3ec8718fb525b4b235790dfbef5060b518d7f88b1f6aa4d545c27c8acb94751d1
MISC metadata.xml 398 BLAKE2B 5a71d80adb94073494d12eb93722d21593a388b4f4cb47ad8ce1e8d053f24d1597c36743e720dabbc023f9318039b45b0b1ddc22d86455394b72789ab0c5e988 SHA512 823dbd0877b3ac042e5c51f260cb0f3d3490383a4975d7bf2267898cad7e3366a693be270d2eb9c8dcea8b7f66d1e6a3343b7a4be5c1b8f0fff8ffe514952e5a
diff --git a/dev-python/flake8/flake8-3.9.0.ebuild b/dev-python/flake8/flake8-3.9.0.ebuild
new file mode 100644
index 000000000000..4b9b899ae918
--- /dev/null
+++ b/dev-python/flake8/flake8-3.9.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="A wrapper around PyFlakes, pep8 & mccabe"
+HOMEPAGE="https://gitlab.com/pycqa/flake8 https://pypi.org/project/flake8/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-macos"
+
+# requires.txt inc. mccabe however that creates a circular dep
+RDEPEND="
+ >=dev-python/pyflakes-2.3.0[${PYTHON_USEDEP}]
+ <dev-python/pyflakes-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/pycodestyle-2.7.0[${PYTHON_USEDEP}]
+ <dev-python/pycodestyle-2.8.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/importlib_metadata[${PYTHON_USEDEP}]' pypy3 python3_{6,7})
+"
+PDEPEND="
+ >=dev-python/mccabe-0.6.0[${PYTHON_USEDEP}]
+ <dev-python/mccabe-0.7.0[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}
+ test? (
+ ${PDEPEND}
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source dev-python/sphinx-prompt dev-python/sphinx_rtd_theme
+distutils_enable_tests --install pytest