summaryrefslogtreecommitdiff
path: root/dev-python/flake8
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-03-31 01:33:08 +0100
committerV3n3RiX <venerix@koprulu.sector>2025-03-31 01:33:08 +0100
commit033286afc1eb2e64a87a58798a0c620d8b56f497 (patch)
tree4793d794ccd00b0efa754d9fd07ad01694c17e0f /dev-python/flake8
parent5ddc3e2d8f01496ed8b9a87cbe9c939f8f317eff (diff)
gentoo auto-resync : 31:03:2025 - 01:33:08
Diffstat (limited to 'dev-python/flake8')
-rw-r--r--dev-python/flake8/Manifest2
-rw-r--r--dev-python/flake8/flake8-7.2.0.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/flake8/Manifest b/dev-python/flake8/Manifest
index f3d1be0a0a04..4e975aed5481 100644
--- a/dev-python/flake8/Manifest
+++ b/dev-python/flake8/Manifest
@@ -1,3 +1,5 @@
DIST flake8-7.1.2.gh.tar.gz 139099 BLAKE2B 4236a533cbaaa91c4c407af02890189ca65b7ebfe3af711df2cdba02e5a28963fc3622e0a0a41190168f3cd827ccb8fed4561cdcf352642f2660ec361657a43c SHA512 da90d07d45690efa433338ed6fcfaabdf08b5bf600783fa0f22b59f77bc560b81d3e0c8203c8fe92bd0b133f40fccd919d68c65cab9a266ea6f5bd45576b3837
+DIST flake8-7.2.0.gh.tar.gz 139186 BLAKE2B 6ff405b575a1b963dfe46ce487626813be80ef981e1cef3ff81f7068e4485b8ba91a783da9ea235e24b07bc309ad0b6cdfd7bddc85bafbaa0770cbfcaa257e18 SHA512 8478b463aa84cdfb8144fb20db03116593e21cc4ec7dee2b87ac7edcb67cb00ae181a51117c885363f1050a83db5a91a65d52c3d8d80affb0a5e526e56792f26
EBUILD flake8-7.1.2.ebuild 1489 BLAKE2B 81047c491c510b9698f97ce770f400a4992b96c3a9d6bcf62ca6f25eb770278b86fd0839ccc1d1dd9eaba141f0eaee4eeb7a1da84c76cdb1aa5ab6af3a6d760a SHA512 95478da84c4f26ada4d1b1e39114323ec1d7f3b12d35fe9247819387eaad95697d9d20be7c1ba206bf7f6d753ea0e4d012ecbd70cf143cfc6b8a9b2ac5634ac5
+EBUILD flake8-7.2.0.ebuild 1497 BLAKE2B de484f2b7eb757a2af200dbb96212c2e32fc23ca97d62f497f1814b8c780c556cf40dd1e613b11acfba7afc6b3f9000ef9fd7fae91689b5ead3a174321d13e7d SHA512 3e6e8a8837dd14a2d40f554d6365d8a44bb0db4f599cafc64fd5026cf566897104ea2609ad1f6e99250e18c2e4274f941e6f0df585b7c8c3dbc08f7a3365e08e
MISC metadata.xml 399 BLAKE2B 01ae165c898af67195582e1aaf867b9f9fc937e56b87f09a812d21c9d1175131c25561524ba76857c1630a117a21bc43eeef907c2a34ab9e9b38866dc2f9430e SHA512 8f149a017f4fef8f8fe0fef037e589694e0c3b3689990f97f38ed23fb9b5c5170985fc1fd7814ef70b8200db66cb9367dcfc9bf6453f8742092335a1c3c8fae6
diff --git a/dev-python/flake8/flake8-7.2.0.ebuild b/dev-python/flake8/flake8-7.2.0.ebuild
new file mode 100644
index 000000000000..663c04731b0f
--- /dev/null
+++ b/dev-python/flake8/flake8-7.2.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 pypy3_11 python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="A wrapper around PyFlakes, pep8 & mccabe"
+HOMEPAGE="
+ https://github.com/PyCQA/flake8/
+ https://pypi.org/project/flake8/
+"
+SRC_URI="
+ https://github.com/PyCQA/flake8/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ =dev-python/pyflakes-3.3*[${PYTHON_USEDEP}]
+ =dev-python/pycodestyle-2.13*[${PYTHON_USEDEP}]
+"
+PDEPEND="
+ =dev-python/mccabe-0.7*[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ ${PDEPEND}
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ dev-python/sphinx-prompt \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # fails if additional flake8 plugins are installed
+ tests/integration/test_plugins.py::test_local_plugin_can_add_option
+ )
+ case ${EPYTHON} in
+ pypy3*)
+ EPYTEST_DESELECT+=(
+ # problem with pypy3.10 in dev-python/pyflakes
+ # https://github.com/PyCQA/pyflakes/issues/779
+ tests/integration/test_main.py::test_malformed_per_file_ignores_error
+ tests/integration/test_main.py::test_tokenization_error_but_not_syntax_error
+ tests/integration/test_main.py::test_tokenization_error_is_a_syntax_error
+ )
+ ;;
+ esac
+
+ epytest
+}