summaryrefslogtreecommitdiff
path: root/dev-python/flake8-polyfill
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-04 21:16:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-04 21:16:38 +0000
commitf932718a139f93e19a6883c061f81b365a408592 (patch)
tree216b44e4ea101b2d02ea32782355ed127f7b1df4 /dev-python/flake8-polyfill
parentf5f1e7d30401ef31b8776c96a80cf5caae0a4e81 (diff)
gentoo auto-resync : 04:11:2022 - 21:16:37
Diffstat (limited to 'dev-python/flake8-polyfill')
-rw-r--r--dev-python/flake8-polyfill/Manifest5
-rw-r--r--dev-python/flake8-polyfill/flake8-polyfill-1.0.2-r1.ebuild32
-rw-r--r--dev-python/flake8-polyfill/flake8-polyfill-1.0.2.ebuild2
-rw-r--r--dev-python/flake8-polyfill/metadata.xml1
4 files changed, 37 insertions, 3 deletions
diff --git a/dev-python/flake8-polyfill/Manifest b/dev-python/flake8-polyfill/Manifest
index 9b7b2239bb8f..a729e202b513 100644
--- a/dev-python/flake8-polyfill/Manifest
+++ b/dev-python/flake8-polyfill/Manifest
@@ -1,3 +1,4 @@
DIST flake8-polyfill-1.0.2.tar.gz 7591 BLAKE2B 59c55e054b04098ad2e1c95d3464f3582fdfe2a83da75c8cebf556e2e7e32abeccf1bf69ec2d0b5c9790179d1c905da21b27e60e1c9810b62502c455193851fe SHA512 767a599aacbe87328b3e36bd85e0841870760ed9bd95dd3a4a9084edc6f0ae89f8203d565c2b075f16f1db21b647c17b2aa59b08e4702109d7e5f79f36d9f3fa
-EBUILD flake8-polyfill-1.0.2.ebuild 751 BLAKE2B a5d151de87c3f698ee456b9d260c112caa14d3d43662f622ea8b1675fd7b1c1fe07ef8745c98370f069f3f5e8f384695c9718fd01ac9bbbe13ae2d5f1387de0c SHA512 cbdf3b2490a6460f637ce014896aa53f258b0f43ced1c63c99c2922c3f51eb17b69715fe47d8346d84c6c5996c2f6771f9cba0f7cade55c7acbcb16465a8d630
-MISC metadata.xml 321 BLAKE2B ab71ce26e6578053020b11b3a3cfc43ec2e5169c16895c9a0e74463169dc590422dd784c46098a197610b86defe55b6343efc4267d64c6f96760a48b793caca8 SHA512 0599d1542a14f64b54e369713d0cbd293ff9d044ac98b6c6ee3a48748750b11550279142630d7b6f814558b576d5b5e4134f13c1a91bd0638bdf3113820d5ef1
+EBUILD flake8-polyfill-1.0.2-r1.ebuild 783 BLAKE2B 32d8c0d8bb878c2306eaf58e826c819631ebad2c2587fb4803880695a3146b0e9c6a362455d1c69793277b504fd6786e71901a72890948177133b2ff5e892e10 SHA512 0b2b88b42e5ae1243b62e4792631a3fc5ef5c7a059ac3bfd35f0cc3dc34b820638e7538011a6e637bc0a02ece4f5606c00a1e853d9b7ff554aba73fd96f41b9c
+EBUILD flake8-polyfill-1.0.2.ebuild 751 BLAKE2B 57c20ae397462dfb2e8f028d1499f6296b446efa18f77d23aa0c85648243052967d1e6f692815d1d9363ef845550ba2321fb06dd0283377981a24aa80db68c47 SHA512 c60bdfe66956ae529a8f82c0a84753b11ee7499c2cffc7a2c4d7eeac5a74db6385dfc6f92b35b5871007c94b92bf1071ee432de2e1ed54a1e732a99f6a0bbd87
+MISC metadata.xml 382 BLAKE2B 500aa9900d66a01995a722b1874b16f8d0f3926bff3e007f79ebb7ac538ca14785a6a1196088bdd43524d804efc9863a7f564b208a6d2a29326caf24d3014d5d SHA512 af899ea40e06b94302407afd4afa0dc3aaa94d808b104ba5e38086617c12100a5c5867169650c8b523a893a876b5e5c803cbca293c8780ba75bb59bfe2720e82
diff --git a/dev-python/flake8-polyfill/flake8-polyfill-1.0.2-r1.ebuild b/dev-python/flake8-polyfill/flake8-polyfill-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..43a2e3378dbd
--- /dev/null
+++ b/dev-python/flake8-polyfill/flake8-polyfill-1.0.2-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1
+
+DESCRIPTION="Polyfill package for Flake8 plugins"
+HOMEPAGE="https://gitlab.com/pycqa/flake8-polyfill"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/flake8[${PYTHON_USEDEP}]"
+BDEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # Get rid of the test that seems to test only the migration from
+ # pep8 to pycodestyle (bug 598918).
+ tests/test_stdin.py
+)
+
+src_prepare() {
+ sed -e 's|\[pytest\]|\[tool:pytest\]|' -i setup.cfg || die
+ distutils-r1_src_prepare
+}
diff --git a/dev-python/flake8-polyfill/flake8-polyfill-1.0.2.ebuild b/dev-python/flake8-polyfill/flake8-polyfill-1.0.2.ebuild
index e9866fde8326..750f32742879 100644
--- a/dev-python/flake8-polyfill/flake8-polyfill-1.0.2.ebuild
+++ b/dev-python/flake8-polyfill/flake8-polyfill-1.0.2.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..11} )
inherit distutils-r1
DESCRIPTION="Polyfill package for Flake8 plugins"
diff --git a/dev-python/flake8-polyfill/metadata.xml b/dev-python/flake8-polyfill/metadata.xml
index a011ff124337..1e661ba0fbb8 100644
--- a/dev-python/flake8-polyfill/metadata.xml
+++ b/dev-python/flake8-polyfill/metadata.xml
@@ -7,5 +7,6 @@
<stabilize-allarches/>
<upstream>
<remote-id type="pypi">flake8-polyfill</remote-id>
+ <remote-id type="gitlab">pycqa/flake8-polyfill</remote-id>
</upstream>
</pkgmetadata>