summaryrefslogtreecommitdiff
path: root/dev-python/flake8-polyfill
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/flake8-polyfill
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/flake8-polyfill')
-rw-r--r--dev-python/flake8-polyfill/Manifest3
-rw-r--r--dev-python/flake8-polyfill/flake8-polyfill-1.0.1.ebuild28
-rw-r--r--dev-python/flake8-polyfill/metadata.xml10
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/flake8-polyfill/Manifest b/dev-python/flake8-polyfill/Manifest
new file mode 100644
index 000000000000..369aaa801c05
--- /dev/null
+++ b/dev-python/flake8-polyfill/Manifest
@@ -0,0 +1,3 @@
+DIST flake8-polyfill-1.0.1.tar.gz 8094 BLAKE2B 1e93503b7f45da1d2f8086ea7e2f619df73a68f6680e958fd1dc13dfa0409ecaf0a045e1a6fbb3634279b17479e7227d68412d97c16d3a87182ae2a3e2c7cc11 SHA512 cdb1530c004015fc44007eb4efb5a84b2ff6f22bf75b3a33ada0c0e80eca5e137a2504baea11ae186018ff7617c8935bc14c36703c17c533a27abc81f9856883
+EBUILD flake8-polyfill-1.0.1.ebuild 721 BLAKE2B ad8762c91e8ff937a2db637ec9e9c3d9d5fbc5b4ad9d4de8ac9eb444c411dc902b214ed40021db09850a8a83d173bfe1d65cfd2ee0660bc1f966402c23af8cfa SHA512 fa7242a9da9c47a6288fc2342d9850dffda0c45c8748c59f46d08988b21a1082c180c4f82799410d11e0853fd7a1d0fa2238a4c3e6e2a5861d2d4f393bdb90dc
+MISC metadata.xml 296 BLAKE2B 1b6ed3723bc9c8b200aa8edeac760400493117046f88144e6684c41326de6b5c0c17fb474e9d25a6f4b75ec55d3a699ea3f0134d204e95551f143f8bb935f5f3 SHA512 8a15e9dc8f9ff3ffcb88147950d11ab9dfe69124bb8aa9293c5b3582044ddda95acc0f62453667f53a732dc98f984ca40c8739e965edfa3e8db4f61ecebcdc1b
diff --git a/dev-python/flake8-polyfill/flake8-polyfill-1.0.1.ebuild b/dev-python/flake8-polyfill/flake8-polyfill-1.0.1.ebuild
new file mode 100644
index 000000000000..ce45dac7f78a
--- /dev/null
+++ b/dev-python/flake8-polyfill/flake8-polyfill-1.0.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )
+inherit distutils-r1
+
+DESCRIPTION="Polyfill package for Flake8 plugins"
+HOMEPAGE="https://gitlab.com/pycqa/flake8"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+EGIT_REPO_URI="https://gitlab.com/pycqa/flake8-polyfill.git"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/flake8[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ py.test -v || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/flake8-polyfill/metadata.xml b/dev-python/flake8-polyfill/metadata.xml
new file mode 100644
index 000000000000..43729a6574c5
--- /dev/null
+++ b/dev-python/flake8-polyfill/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">flake8-polyfill</remote-id>
+ </upstream>
+</pkgmetadata>