summaryrefslogtreecommitdiff
path: root/dev-python/flake8-polyfill
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/flake8-polyfill
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/flake8-polyfill')
-rw-r--r--dev-python/flake8-polyfill/Manifest4
-rw-r--r--dev-python/flake8-polyfill/flake8-polyfill-1.0.1.ebuild28
-rw-r--r--dev-python/flake8-polyfill/metadata.xml14
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/flake8-polyfill/Manifest b/dev-python/flake8-polyfill/Manifest
new file mode 100644
index 000000000000..8936b376aad0
--- /dev/null
+++ b/dev-python/flake8-polyfill/Manifest
@@ -0,0 +1,4 @@
+DIST flake8-polyfill-1.0.1.tar.gz 8094 SHA256 c77056b1e2cfce7b39d7634370062baf02438962a7d176ea717627b83b17f609 SHA512 cdb1530c004015fc44007eb4efb5a84b2ff6f22bf75b3a33ada0c0e80eca5e137a2504baea11ae186018ff7617c8935bc14c36703c17c533a27abc81f9856883 WHIRLPOOL f9e3b2938d4683cccf13885a40348c7d5e8dbcb3e5808edbebc8538b28b573e399009f12317c926adccdbb2ab78fc7adc07ea495935b03f0454a33974a5cc97b
+EBUILD flake8-polyfill-1.0.1.ebuild 721 SHA256 8361cd10e0293152c983e1d4484e51277f402575c2c147b9fcb79c9dd091bfcb SHA512 fa7242a9da9c47a6288fc2342d9850dffda0c45c8748c59f46d08988b21a1082c180c4f82799410d11e0853fd7a1d0fa2238a4c3e6e2a5861d2d4f393bdb90dc WHIRLPOOL a543aa2fb8932c68eab1fbaf1750b19a1671d466710d2805df2c21223d9552f9ff69f8b6d99845322993c3a5b85b4c89ad99f71a9fdb4ccb6722742035afa3d0
+MISC ChangeLog 336 SHA256 435dd50e313d14b068ebf726db120af50b901f69c7401ae2024735430ecb1c10 SHA512 3f837dc88bbc625f9eeaf834988464fc793dfc0e5a0ea5b9957c07e6842d41c34245068629a77eafe5593b9aa8bc9f07493c98eb6e46d1092201b2b4f0165092 WHIRLPOOL 4f168d7add4faac6f47855d623a7f1a44fdf609e98b8bd3731b19cccda4cf90de615f3a914d1da7a4318aa77dccc6a0a1dc5852a6c451a9aa4465ec38d677955
+MISC metadata.xml 403 SHA256 dfc632480f9a5cffbb892d74beaa178fde3632cfcf165269ba7b1a328d483c11 SHA512 c75c5e09521f7f8c98806f04832d838e8cafeead79aef8c0aafbecd6da9dfb37f654cc759c25afe874f72deb9e96597574a02a3c8518f20ed98bd9c4ad36fcdf WHIRLPOOL 138790976a51469450174ddc79dcbabc82b154fd1db687d5b957ebc73ca4879f120eb42f6cc681d376def18dce155f94b6134c1e8a54bb10aebf97d067a4327a
diff --git a/dev-python/flake8-polyfill/flake8-polyfill-1.0.1.ebuild b/dev-python/flake8-polyfill/flake8-polyfill-1.0.1.ebuild
new file mode 100644
index 000000000000..ce45dac7f78a
--- /dev/null
+++ b/dev-python/flake8-polyfill/flake8-polyfill-1.0.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )
+inherit distutils-r1
+
+DESCRIPTION="Polyfill package for Flake8 plugins"
+HOMEPAGE="https://gitlab.com/pycqa/flake8"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+EGIT_REPO_URI="https://gitlab.com/pycqa/flake8-polyfill.git"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/flake8[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ py.test -v || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/flake8-polyfill/metadata.xml b/dev-python/flake8-polyfill/metadata.xml
new file mode 100644
index 000000000000..8f3fcce9a54b
--- /dev/null
+++ b/dev-python/flake8-polyfill/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>alunduil@gentoo.org</email>
+ <name>Alex Brandt</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">flake8-polyfill</remote-id>
+ </upstream>
+</pkgmetadata>