summaryrefslogtreecommitdiff
path: root/dev-python/flake8-polyfill
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
commit2fd57282f0262ca084e05b0f2c63fbada395d02b (patch)
tree4e0f23cea9ce9fd972e70ebc5214bf36fed465cc /dev-python/flake8-polyfill
parentc3bc61051d7f12b4c682efa7a5460bbc8815649e (diff)
gentoo resync : 16.01.2021
Diffstat (limited to 'dev-python/flake8-polyfill')
-rw-r--r--dev-python/flake8-polyfill/Manifest2
-rw-r--r--dev-python/flake8-polyfill/flake8-polyfill-1.0.2.ebuild24
2 files changed, 11 insertions, 15 deletions
diff --git a/dev-python/flake8-polyfill/Manifest b/dev-python/flake8-polyfill/Manifest
index 8031c6934327..9b7b2239bb8f 100644
--- a/dev-python/flake8-polyfill/Manifest
+++ b/dev-python/flake8-polyfill/Manifest
@@ -1,3 +1,3 @@
DIST flake8-polyfill-1.0.2.tar.gz 7591 BLAKE2B 59c55e054b04098ad2e1c95d3464f3582fdfe2a83da75c8cebf556e2e7e32abeccf1bf69ec2d0b5c9790179d1c905da21b27e60e1c9810b62502c455193851fe SHA512 767a599aacbe87328b3e36bd85e0841870760ed9bd95dd3a4a9084edc6f0ae89f8203d565c2b075f16f1db21b647c17b2aa59b08e4702109d7e5f79f36d9f3fa
-EBUILD flake8-polyfill-1.0.2.ebuild 904 BLAKE2B e3b4f141c00155080465a6355b2f01225d0ab124fa32987e0f94ab0839dfe9cbbe6a27d407392d2df6178f0685fc749e13498f2dbc8142636a09c5f8a1c36194 SHA512 f28107c9d8cdab611d2e2df3bd6bcc28e21862f91eac63aa2617f78168ad80812622dc1b512ddbf74a9bdbc38928f09b5a912709d59c25456767f0caf0dce7e7
+EBUILD flake8-polyfill-1.0.2.ebuild 751 BLAKE2B a5d151de87c3f698ee456b9d260c112caa14d3d43662f622ea8b1675fd7b1c1fe07ef8745c98370f069f3f5e8f384695c9718fd01ac9bbbe13ae2d5f1387de0c SHA512 cbdf3b2490a6460f637ce014896aa53f258b0f43ced1c63c99c2922c3f51eb17b69715fe47d8346d84c6c5996c2f6771f9cba0f7cade55c7acbcb16465a8d630
MISC metadata.xml 321 BLAKE2B ab71ce26e6578053020b11b3a3cfc43ec2e5169c16895c9a0e74463169dc590422dd784c46098a197610b86defe55b6343efc4267d64c6f96760a48b793caca8 SHA512 0599d1542a14f64b54e369713d0cbd293ff9d044ac98b6c6ee3a48748750b11550279142630d7b6f814558b576d5b5e4134f13c1a91bd0638bdf3113820d5ef1
diff --git a/dev-python/flake8-polyfill/flake8-polyfill-1.0.2.ebuild b/dev-python/flake8-polyfill/flake8-polyfill-1.0.2.ebuild
index da199eabc872..e9866fde8326 100644
--- a/dev-python/flake8-polyfill/flake8-polyfill-1.0.2.ebuild
+++ b/dev-python/flake8-polyfill/flake8-polyfill-1.0.2.ebuild
@@ -1,35 +1,31 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Polyfill package for Flake8 plugins"
HOMEPAGE="https://gitlab.com/pycqa/flake8-polyfill"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-EGIT_REPO_URI="https://gitlab.com/pycqa/flake8-polyfill.git"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="dev-python/flake8[${PYTHON_USEDEP}]"
-DEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pycodestyle[${PYTHON_USEDEP}]
- )"
+BDEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}] )"
distutils_enable_tests pytest
-python_prepare_all() {
+EPYTEST_IGNORE=(
# Get rid of the test that seems to test only the migration from
# pep8 to pycodestyle (bug 598918).
- rm "tests/test_stdin.py" || die
+ tests/test_stdin.py
+)
+
+src_prepare() {
sed -e 's|\[pytest\]|\[tool:pytest\]|' -i setup.cfg || die
- distutils-r1_python_prepare_all
+ distutils-r1_src_prepare
}