summaryrefslogtreecommitdiff
path: root/dev-python/fitsio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/fitsio
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/fitsio')
-rw-r--r--dev-python/fitsio/Manifest4
-rw-r--r--dev-python/fitsio/files/fitsio-0.9.11-test-failures.patch38
-rw-r--r--dev-python/fitsio/fitsio-0.9.11.ebuild40
-rw-r--r--dev-python/fitsio/metadata.xml21
4 files changed, 103 insertions, 0 deletions
diff --git a/dev-python/fitsio/Manifest b/dev-python/fitsio/Manifest
new file mode 100644
index 000000000000..c102a86bf646
--- /dev/null
+++ b/dev-python/fitsio/Manifest
@@ -0,0 +1,4 @@
+AUX fitsio-0.9.11-test-failures.patch 1560 SHA256 f16f2d480acd63bd2dfc27df3d95c5e6720d66c31e4198063993cfa9c6179d8a SHA512 224ae91e65d4b5f24cd64f3ab389940bfa58801822ad090966c4c570d5c9fb568588b3efa1dab73c2ebbbd0b5f802c2364fda31097811da78c09903814613c6b WHIRLPOOL 4e7537ab5f0203f5b47347b5732ccd13aa738c0927c6e99651d75ca8ace0ea4e38c1679c97dea4856124ba7fcd8bdc25b8397a15d884d17da7f863106efc2354
+DIST fitsio-0.9.11.tar.gz 6020222 SHA256 a1196385ca7c42c93d9e53002d5ba574a8db452c3b53ef1189e2c150177d4266 SHA512 751b9612fe051f128d8f5dea61e2d119409293051a130ee3e18836181637e8c8daea757a715012fd024678d00e234e8b6c0cc0c9229c2bd9a406db312e4607d7 WHIRLPOOL b1baeef81675b089fc176d2c83766fc535e0fe5f1841b8ecf3b37ce8a336f05c9d61791fa5d7d010a115f300560ffe499eed291c12c3ed2633a2651de79f26e9
+EBUILD fitsio-0.9.11.ebuild 944 SHA256 3c0ffc7b287f3c0e6f0501eec7cc32bbf0940740dcf1c5555387b941dd1ba09b SHA512 bb5e7bc6d307595cd5ee9258bea43cec4213917d5efcd2e65096da7dc04fd95674a6fefed304e865e06436c2512c9ee2cd8c912228ae8718582a75a3f0c286ab WHIRLPOOL 264678c1195996196bf100bc9870ae2eceaf92a3b5b62f3d916f0481ca9a1069a34d2f5e70dccbbd278042cccf3239a6cbddb05fa244e9f7d40e41a855f11cad
+MISC metadata.xml 930 SHA256 6eefa6476052f6920a6a7935c8899edb2ad111fc6790115b375a0a9896348284 SHA512 ef4d3c9838e4e151b16febdacb9fb3b3538763dfb0c08b43ad73a9d9ecbdb275d91152b64b400aec8e3d337f08f3aa46cc166251e34142a68514135d6ae314d4 WHIRLPOOL 3b7499d28fa8237420e3f63bff0542440d9ed011d41e50d79970303f81d90f1d206f67e1e117327eda77bdee2742147a3e931a7d4dc7a76dcb5e46510108bcf4
diff --git a/dev-python/fitsio/files/fitsio-0.9.11-test-failures.patch b/dev-python/fitsio/files/fitsio-0.9.11-test-failures.patch
new file mode 100644
index 000000000000..243913dc659e
--- /dev/null
+++ b/dev-python/fitsio/files/fitsio-0.9.11-test-failures.patch
@@ -0,0 +1,38 @@
+From: Ole Streicher <olebole@debian.org>
+Date: Fri, 15 Jul 2016 08:46:15 +0200
+Subject: Mark failures that are known to fail with the original cfitsio
+
+---
+ fitsio/test.py | 5 +++--
+ 1 file changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/fitsio/test.py b/fitsio/test.py
+index bafde15..49a4b3b 100644
+--- a/fitsio/test.py
++++ b/fitsio/test.py
+@@ -545,7 +545,7 @@ class TestReadWrite(unittest.TestCase):
+ try:
+ with fitsio.FITS(fname,'rw',clobber=True) as fits:
+ # note i8 not supported for compressed!
+- dtypes = ['u1','i1','u2','i2','u4','i4','f4','f8']
++ dtypes = ['u1','i1', 'i2','u4','i4','f4','f8']
+
+ for dtype in dtypes:
+ data = numpy.arange(5*20,dtype=dtype).reshape(5,20)
+@@ -569,7 +569,7 @@ class TestReadWrite(unittest.TestCase):
+ try:
+ with fitsio.FITS(fname,'rw',clobber=True) as fits:
+ # note i8 not supported for compressed!
+- dtypes = ['u1','i1','u2','i2','u4','i4','f4','f8']
++ dtypes = ['u1','i1', 'i2','u4','i4','f4','f8']
+
+ for dtype in dtypes:
+ data = numpy.arange(5*20,dtype=dtype).reshape(5,20)
+@@ -1365,6 +1365,7 @@ class TestReadWrite(unittest.TestCase):
+ if os.path.exists(fname):
+ os.remove(fname)
+
++ @unittest.skip("bzip2 is not supported with debian cfitsio package")
+ def testBz2Read(self):
+ '''
+ Write a normal .fits file, run bzip2 on it, then read the bz2
diff --git a/dev-python/fitsio/fitsio-0.9.11.ebuild b/dev-python/fitsio/fitsio-0.9.11.ebuild
new file mode 100644
index 000000000000..cf3d78bf88dd
--- /dev/null
+++ b/dev-python/fitsio/fitsio-0.9.11.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library to read from and write to FITS files"
+HOMEPAGE="https://github.com/esheldon/fitsio"
+SRC_URI="https://github.com/esheldon/fitsio/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/numpy-1.11[${PYTHON_USEDEP}]
+ sci-libs/cfitsio:0=
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+PATCHES=( "${FILESDIR}"/${P}-test-failures.patch )
+
+python_prepare_all() {
+ sed -e '/self.use_system_fitsio/s/False/True/' \
+ -i setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ distutils_install_for_testing
+ pushd "${TEST_DIR}"/ || die
+ ${PYTHON} -c "import fitsio; exit(fitsio.test.test())" || die
+ popd > /dev/null || die
+}
diff --git a/dev-python/fitsio/metadata.xml b/dev-python/fitsio/metadata.xml
new file mode 100644
index 000000000000..b7f5bc4ce9ac
--- /dev/null
+++ b/dev-python/fitsio/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-astronomy@gentoo.org</email>
+ <name>Gentoo Astronomy Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Fitsio provides an easy to use object-oriented API including
+ providing a Numpy interface to FITS files read from CFITSIO. It
+ allows direct access to the columns of a FITS binary table which can
+ be useful for reading large fits files. Compared to astropy.io.fits,
+ this package is closer to the underlying cfitsio library.
+ Fitsio also exposes a microlanguage (implemented in CFITSIO) for
+ making efficient SQL-like queries of tables (single tables only
+ though–no joins or anything like that).
+ </longdescription>
+ <upstream>
+ <remote-id type="github">esheldon/fitsio</remote-id>
+ </upstream>
+</pkgmetadata>