summaryrefslogtreecommitdiff
path: root/dev-python/fitsio/fitsio-0.9.11.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
commit0c100b7dd2b30e75b799d806df4ef899fd98e1ea (patch)
tree464c922e949c7e4d5d891fb2cdda5daee5612537 /dev-python/fitsio/fitsio-0.9.11.ebuild
parente68d405c5d712af4387159df07e226217bdda049 (diff)
gentoo resync : 16.04.2022
Diffstat (limited to 'dev-python/fitsio/fitsio-0.9.11.ebuild')
-rw-r--r--dev-python/fitsio/fitsio-0.9.11.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/dev-python/fitsio/fitsio-0.9.11.ebuild b/dev-python/fitsio/fitsio-0.9.11.ebuild
deleted file mode 100644
index c58f52da2827..000000000000
--- a/dev-python/fitsio/fitsio-0.9.11.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python library to read from and write to FITS files"
-HOMEPAGE="https://github.com/esheldon/fitsio"
-SRC_URI="https://github.com/esheldon/fitsio/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- >=dev-python/numpy-1.11[${PYTHON_USEDEP}]
- sci-libs/cfitsio:0=
-"
-DEPEND="${RDEPEND}"
-
-PATCHES=( "${FILESDIR}"/${P}-test-failures.patch )
-
-python_prepare_all() {
- sed -e '/self.use_system_fitsio/s/False/True/' \
- -i setup.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- distutils_install_for_testing
- pushd "${TEST_DIR}"/ || die
- ${PYTHON} -c "import fitsio; exit(fitsio.test.test())" || die
- popd > /dev/null || die
-}