summaryrefslogtreecommitdiff
path: root/dev-python/filelock/filelock-3.12.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-28 22:03:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-28 22:03:36 +0100
commit452411c00cad9fbb22e87ccc5840d8dd78ad9914 (patch)
tree995696599d3d79cdd8f26459c7db4d0f83147575 /dev-python/filelock/filelock-3.12.3.ebuild
parenta5509b9be1fe380ed210b8279d996e1f1b03017a (diff)
gentoo auto-resync : 28:08:2023 - 22:03:35
Diffstat (limited to 'dev-python/filelock/filelock-3.12.3.ebuild')
-rw-r--r--dev-python/filelock/filelock-3.12.3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/filelock/filelock-3.12.3.ebuild b/dev-python/filelock/filelock-3.12.3.ebuild
new file mode 100644
index 000000000000..3e8cbe92bc17
--- /dev/null
+++ b/dev-python/filelock/filelock-3.12.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2018-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A platform independent file lock for Python"
+HOMEPAGE="
+ https://github.com/tox-dev/filelock/
+ https://pypi.org/project/filelock/
+"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-4.7.1[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest