summaryrefslogtreecommitdiff
path: root/dev-python/filelock/filelock-3.0.12-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /dev-python/filelock/filelock-3.0.12-r1.ebuild
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'dev-python/filelock/filelock-3.0.12-r1.ebuild')
-rw-r--r--dev-python/filelock/filelock-3.0.12-r1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/filelock/filelock-3.0.12-r1.ebuild b/dev-python/filelock/filelock-3.0.12-r1.ebuild
new file mode 100644
index 000000000000..854abd2c0a6c
--- /dev/null
+++ b/dev-python/filelock/filelock-3.0.12-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2018-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+inherit distutils-r1
+
+MY_P=py-filelock-${PV}
+DESCRIPTION="A platform independent file lock for Python"
+HOMEPAGE="https://github.com/benediktschmitt/py-filelock
+ https://pypi.org/project/filelock/"
+SRC_URI="https://github.com/benediktschmitt/py-filelock/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86"
+IUSE=""
+
+distutils_enable_tests unittest