summaryrefslogtreecommitdiff
path: root/dev-python/fido2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-19 13:06:44 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-19 13:06:44 +0100
commit97967bbbae8f43c98315b079178f1717f130e302 (patch)
tree27523f8cbd75ed85f33294862514b786a30dd6e5 /dev-python/fido2
parent30c53e395853f5bfe805a1e429fcf26666eed8f8 (diff)
gentoo resync : 19.05.2018
Diffstat (limited to 'dev-python/fido2')
-rw-r--r--dev-python/fido2/Manifest3
-rw-r--r--dev-python/fido2/fido2-0.3.0.ebuild35
-rw-r--r--dev-python/fido2/metadata.xml16
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/fido2/Manifest b/dev-python/fido2/Manifest
new file mode 100644
index 000000000000..9ddc945c86dc
--- /dev/null
+++ b/dev-python/fido2/Manifest
@@ -0,0 +1,3 @@
+DIST fido2-0.3.0.tar.gz 125907 BLAKE2B 95054f258c775ac3b4f65608fd3b62ec4165a568c237064ebb66da1ca6ae899a3d88b5613e9dd4be87c05068ebd698be452dd3467800317e5894092216196e12 SHA512 c6ea83e104d77350413156eba4c1aa2635b77ae00d157dce61e5a8539c65aca4dd1dfc5303f9d408359582eeb98ae558aa1e2043a9b1dfcb23415eb8bc9c6a09
+EBUILD fido2-0.3.0.ebuild 820 BLAKE2B 5a50bac620a129267b34b051c0a4d310ea57829fa8b3dd7273e6e2a1309c6e773aa452184d12d7cbd7ff4351a4cabc0327e49eb55744479ba142acac5157e3b6 SHA512 f0a4f6967e6e88178b9aae95de79153b037bca6766ea89e9f6ab36eb6cb2fc4364f716eec4793637f96a045faecaf02fc7c97684b901d9012d56b576cc43e88f
+MISC metadata.xml 516 BLAKE2B c8d1710daa727f863e8936fcd4d2374c174ba6f1224d7c66d498bd9353e165b5659d3239d730bf406cd18adaf0acbe1446ebd3d2e3d0baf4fe28e512ac70fea6 SHA512 18f926acaf096999fb70f2942e81ff76effd0f769defbc975653992282ede547c2403df64937edb4d183dc3e218c0183ceb39f343349502f6ff9052db1446090
diff --git a/dev-python/fido2/fido2-0.3.0.ebuild b/dev-python/fido2/fido2-0.3.0.ebuild
new file mode 100644
index 000000000000..80c22c109c07
--- /dev/null
+++ b/dev-python/fido2/fido2-0.3.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+inherit distutils-r1
+
+DESCRIPTION="Python based FIDO 2.0 library"
+HOMEPAGE="https://github.com/Yubico/python-fido2"
+SRC_URI="https://github.com/Yubico/python-fido2/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD-2 MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7)
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pyfakefs[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ touch "${S}"/test/__init__.py || die
+ esetup.py test
+}
diff --git a/dev-python/fido2/metadata.xml b/dev-python/fido2/metadata.xml
new file mode 100644
index 000000000000..b0754694d806
--- /dev/null
+++ b/dev-python/fido2/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>gokturk@gentoo.org</email>
+ <name>Göktürk Yüksek</name>
+</maintainer>
+<longdescription>
+ fido2 provides library functionality for communicating with a FIDO
+ device over USB as well as verifying attestation and assertion
+ signatures.
+</longdescription>
+<upstream>
+ <remote-id type="github">Yubico/python-fido2</remote-id>
+</upstream>
+</pkgmetadata>